summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2017-01-05 18:36:49 -0500
committerSergio Correia2017-01-05 18:36:49 -0500
commitf7a13566666ca148c7344f30506129dad56bdeda (patch)
tree4c9d9beff5aa689e5f599ca4ee8241972ddb4ce4
downloadaur-f7a13566666ca148c7344f30506129dad56bdeda.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec8dd9f010ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.0.1
+# Thu Jan 5 23:07:44 UTC 2017
+pkgbase = python2-pytyle1-git
+ pkgdesc = An extremely versatile and extensible tiling manager that is meant to be embedded into EWMH window managers
+ pkgver = r30.fec5546
+ pkgrel = 1
+ url = https://github.com/BurntSushi/pytyle1
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-xlib
+ source = python2-pytyle1::git+https://github.com/BurntSushi/pytyle1
+ sha256sums = SKIP
+
+pkgname = python2-pytyle1-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2313e56a206f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+
+pkgname='python2-pytyle1-git'
+_pkgname='python2-pytyle1'
+pkgver=r30.fec5546
+pkgrel=1
+pkgdesc="An extremely versatile and extensible tiling manager that is meant
+to be embedded into EWMH window managers"
+arch=("any")
+url="https://github.com/BurntSushi/pytyle1"
+license=('GPL')
+makedepends=('git')
+depends=('python2-xlib')
+source=($_pkgname::'git+https://github.com/BurntSushi/pytyle1')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: