summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:21:40 +0200
committerM0Rf302015-06-17 16:21:40 +0200
commit0f360415eda48ea8def7fe98e24f8a6ebc690f60 (patch)
tree0e8705b1813c542f5d223096c9c5e2e2f453adcb
downloadaur-0f360415eda48ea8def7fe98e24f8a6ebc690f60.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30aa40960e56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pyuserinput-git
+ pkgdesc = A module for cross-platform control of the mouse and keyboard in python that is simple to install and use.
+ pkgver = 86.9fd2879
+ pkgrel = 1
+ url = https://github.com/SavinaRoja/PyUserInput
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-xlib
+ source = git+https://github.com/SavinaRoja/PyUserInput.git
+ md5sums = SKIP
+
+pkgname = python2-pyuserinput-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4762a29e4e3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: M0Rf30
+
+pkgname='python2-pyuserinput-git'
+pkgver=86.9fd2879
+pkgrel=1
+pkgdesc="A module for cross-platform control of the mouse and keyboard in python that is simple to install and use."
+url="https://github.com/SavinaRoja/PyUserInput"
+arch=('any')
+license=('GPL3')
+depends=('python2' 'python2-xlib')
+source=('git+https://github.com/SavinaRoja/PyUserInput.git')
+
+package() {
+ cd PyUserInput
+ python2 setup.py install --root="$pkgdir/"
+}
+
+pkgver() {
+ cd PyUserInput
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')