summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-09-03 15:52:43 +0100
committerGrey Christoforo2015-09-03 15:52:43 +0100
commit1f46e02cf9d9b28c2f7e07a9b8125861bc557816 (patch)
tree5f109704bc2f2675a25fc97aeec76b5b71f71b48
downloadaur-1f46e02cf9d9b28c2f7e07a9b8125861bc557816.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a317425eeb71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pyvisa-py
+ pkgdesc = A pure python backend for PyVISA
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/hgrecco/pyvisa-py
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-pyvisa
+ source = https://github.com/hgrecco/pyvisa-py/archive/0.2.tar.gz
+ md5sums = 518b7e0a79d5d841ec22d665e1c6fd12
+
+pkgname = python2-pyvisa-py
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3535a0fbe42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python2-pyvisa-py
+pkgver=0.2
+pkgrel=1
+pkgdesc="A pure python backend for PyVISA"
+arch=('any')
+license=('MIT')
+depends=('python2' 'python2-pyvisa')
+
+_gituser='hgrecco'
+_gitproject='pyvisa-py'
+
+source=(https://github.com/${_gituser}/${_gitproject}/archive/${pkgver}.tar.gz)
+md5sums=('518b7e0a79d5d841ec22d665e1c6fd12')
+url="https://github.com/${_gituser}/${_gitproject}"
+
+package() {
+ cd ${_gitproject}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: