summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-07-14 21:10:02 +0100
committerJoão Figueiredo2020-07-14 21:10:02 +0100
commit6858b687137d1a3194919ed69038917126dd178c (patch)
tree800c8049a71f34475eafad377b52116cd787d1c1
downloadaur-6858b687137d1a3194919ed69038917126dd178c.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9499dd1a03d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pyxattr
+ pkgdesc = Filesystem extended attributes for python 2
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://pypi.org/project/pyxattr/0.6.1/
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = python2
+ source = https://files.pythonhosted.org/packages/36/1d/1a5f3165f330e1a0427636f2bd995dbcc02d0f7660e89458d64806a2ed1e/pyxattr-0.6.1.tar.gz
+ sha256sums = b525843f6b51036198b3b87c4773a5093d6dec57d60c18a1f269dd7059aa16e3
+
+pkgname = python2-pyxattr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64cbf81018cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+
+pkgname=python2-pyxattr
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Filesystem extended attributes for python 2"
+arch=('any')
+url="https://pypi.org/project/pyxattr/$pkgver/"
+license=('LGPL')
+depends=('python2')
+makedepends=('git')
+source=("https://files.pythonhosted.org/packages/36/1d/1a5f3165f330e1a0427636f2bd995dbcc02d0f7660e89458d64806a2ed1e/pyxattr-$pkgver.tar.gz")
+sha256sums=('b525843f6b51036198b3b87c4773a5093d6dec57d60c18a1f269dd7059aa16e3')
+
+build() {
+ cd "$srcdir/${pkgname#*-}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#*-}-$pkgver"
+ install -Dm755 build/lib.linux-x86_64-2.7/xattr.so "$pkgdir/usr/lib/python2.7/site-packages/xattr.so"
+ install -d "$pkgdir/usr/lib/python2.7/site-packages/pyxattr-$pkgver-py2.7.egg-info/"
+ install -Dm644 pyxattr.egg-info/* "$pkgdir/usr/lib/python2.7/site-packages/pyxattr-$pkgver-py2.7.egg-info/"
+}