summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Corley2015-06-08 11:43:53 +0100
committerMartin Corley2015-06-08 11:43:53 +0100
commitef571ca5642db5311e0e2f600d424a4c8f25ca92 (patch)
tree5147b95f3e15f229530dbd6ee148564d683eefad
downloadaur-ef571ca5642db5311e0e2f600d424a4c8f25ca92.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1753963047fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-qprogedit
+ pkgdesc = PyQt4 widget that implements a full-featured text editor
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/smathot/QProgEdit
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = python2-pyqt4
+ depends = python2-qscintilla
+ provides = python2-qprogedit
+ source = python2-qprogedit::git://github.com/smathot/QProgEdit.git#tag=release/2.1.0
+ md5sums = SKIP
+
+pkgname = python2-qprogedit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20c076d5e595
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python2-qprogedit
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="PyQt4 widget that implements a full-featured text editor"
+arch=('i686' 'x86_64')
+url="https://github.com/smathot/QProgEdit"
+license=('GPL3')
+depends=('python2-pyqt4' 'python2-qscintilla')
+makedepends=('git')
+provides=('python2-qprogedit')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/smathot/QProgEdit.git#tag=release/2.1.0')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+
+build() {
+ cd "$srcdir/$pkgname"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}