summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 08:32:20 -0400
committerJameson Pugh2015-06-08 08:32:20 -0400
commit0cc88952dab018e298dbe9f13db4006ae3b59521 (patch)
treed446be7cfee402c899f577fa32dd1ddd2ddbf332
downloadaur-0cc88952dab018e298dbe9f13db4006ae3b59521.tar.gz
Initial commit using aur2git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdba8bec14d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-quantities
+ pkgdesc = Support for physical quantities based on the popular numpy library
+ pkgver = 0.10.1
+ pkgrel = 2
+ url = http://packages.python.org/quantities
+ arch = any
+ license = BSD
+ depends = python2-numpy
+ depends = python2-nose
+ source = http://pypi.python.org/packages/source/q/quantities/quantities-0.10.1.tar.gz
+ sha256sums = 2d27caf31a5e0c37130ac0c14bfa8f9412a5ff1fbf3378a1d6085594776c4315
+
+pkgname = python2-quantities
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b22293778375
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Sebastien Binet <binet@lblbox>
+
+pkgname=python2-quantities
+pkgver=0.10.1
+pkgrel=2
+pkgdesc="Support for physical quantities based on the popular numpy library"
+url="http://packages.python.org/quantities"
+arch=('any')
+license=('BSD')
+depends=('python2-numpy' 'python2-nose')
+source=(http://pypi.python.org/packages/source/q/quantities/quantities-${pkgver}.tar.gz)
+sha256sums=('2d27caf31a5e0c37130ac0c14bfa8f9412a5ff1fbf3378a1d6085594776c4315')
+
+build() {
+ cd "${srcdir}/quantities-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/quantities-${pkgver}"
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}