summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndres Urquijo2015-08-10 15:24:02 -0500
committerAndres Urquijo2015-08-10 15:24:02 -0500
commit0a995c51ba6103a7ea58b76da1d5c52e2c7393d5 (patch)
treecb17e3802b16c508df1d23c31b99e232c8432477
downloadaur-0a995c51ba6103a7ea58b76da1d5c52e2c7393d5.tar.gz
Adding python2-qutip PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50cc113d4729
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-qutip
+ pkgdesc = QuTiP is open-source software for simulating the dynamics of open quantum systems
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = http://qutip.org/index.html
+ arch = any
+ license = GPL3
+ makedepends = cython2
+ makedepends = gcc-fortran
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-matplotlib
+ optdepends = mayavi: Optional. Needed for using the Bloch3d class
+ optdepends = python2-pyqt4: Optional, required only for GUI elements
+ optdepends = texlive-bin: Optional. Needed if using LaTeX in figures
+ source = http://qutip.org/downloads/3.1.0/qutip-3.1.0.tar.gz
+ md5sums = 73aefdc714149fa6e1a03de660f2eb2b
+
+pkgname = python2-qutip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d6c4f804c84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Andres F. Urquijo <alfagalileox@gmail.com>
+_name=qutip
+_pkgname=qutip
+pkgname=python2-qutip
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="QuTiP is open-source software for simulating the dynamics of open quantum systems"
+arch=("any")
+url="http://qutip.org/index.html"
+license=('GPL3')
+depends=("python2-numpy" "python2-scipy" "python2-matplotlib")
+makedepends=("cython2" "gcc-fortran")
+optdepends=(
+ "mayavi: Optional. Needed for using the Bloch3d class"
+ "python2-pyqt4: Optional, required only for GUI elements"
+ "texlive-bin: Optional. Needed if using LaTeX in figures"
+ )
+
+source=("http://qutip.org/downloads/$pkgver/$_name-$pkgver.tar.gz")
+md5sums=('73aefdc714149fa6e1a03de660f2eb2b')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}