summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-07-13 15:29:31 -0300
committerDanilo J. S. Bellini2018-07-13 15:39:02 -0300
commit42233dfb6fde36ce01109855b4762090b26fc980 (patch)
treeb99129fd6fbf76d38aa51c52ac3cd27172faf76b
parent3d94020d5c4082ed7f9a20163ec452379c0be8fd (diff)
downloadaur-42233dfb6fde36ce01109855b4762090b26fc980.tar.gz
v1.0.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a22826d0dcaa..15a1bb7a6c50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-rasterio
pkgdesc = Fast and direct raster I/O for use with Numpy and SciPy (Python 2)
- pkgver = 1.0b1
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/mapbox/rasterio
arch = x86_64
@@ -20,10 +20,8 @@ pkgbase = python2-rasterio
optdepends = python2-boto3: AWS S3 raster access
optdepends = python2-matplotlib: plt object (rio insp), rasterio.plot module
options = !emptydirs
- source = https://files.pythonhosted.org/packages/d1/de/4a0e38dfb6c82304f8f5051babd7ca2603a35eb9805783044acece249565/rasterio-1.0b1.tar.gz
- source = https://raw.githubusercontent.com/mapbox/rasterio/1.0b1/LICENSE.txt
- sha256sums = 0bd8737952e99954d4e86b695cb944bf2b8f2a4d722d9bf4fe81ec5b1b5bd527
- sha256sums = 1c4441fa02d6ced2ea5f3eab586b5aedb25b934ca6d61fce351c18569930b799
+ source = https://files.pythonhosted.org/packages/33/22/ad2ea27c9829582ab5280f35cc61e424970ce0add34e258c9e171a62cb73/rasterio-1.0.0.tar.gz
+ sha256sums = 6f2e90f2b740d727b36e39550e2a949d52551717812f9b4748f9bc351d666274
pkgname = python2-rasterio
diff --git a/PKGBUILD b/PKGBUILD
index 085dbb7c619e..65031ca77b45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
_name=rasterio
pkgname=('python2-rasterio')
-pkgver=1.0b1
+pkgver=1.0.0
pkgrel=1
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy (Python 2)"
arch=('x86_64')
@@ -15,12 +15,10 @@ optdepends=('ipython2: Alternative inspector interpreter (rio insp --ipython)'
'python2-boto3: AWS S3 raster access'
'python2-matplotlib: plt object (rio insp), rasterio.plot module')
options=(!emptydirs)
-sha256sums=('0bd8737952e99954d4e86b695cb944bf2b8f2a4d722d9bf4fe81ec5b1b5bd527'
- '1c4441fa02d6ced2ea5f3eab586b5aedb25b934ca6d61fce351c18569930b799')
+sha256sums=('6f2e90f2b740d727b36e39550e2a949d52551717812f9b4748f9bc351d666274')
_pypi='https://files.pythonhosted.org/packages'
-_path='d1/de/4a0e38dfb6c82304f8f5051babd7ca2603a35eb9805783044acece249565'
-source=("$_pypi/$_path/$_name-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/mapbox/$_name/$pkgver/LICENSE.txt")
+_path='33/22/ad2ea27c9829582ab5280f35cc61e424970ce0add34e258c9e171a62cb73'
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz")
build() {
cd "$srcdir/rasterio-$pkgver"
@@ -30,6 +28,5 @@ build() {
package() {
cd "$srcdir/rasterio-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 ../LICENSE.txt \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}