summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2018-07-29 13:33:19 +0200
committerBrainDamage2018-07-29 13:33:19 +0200
commitb66197ec5613f2eabbf9717dc4672592e5bc55fd (patch)
tree80c4369cec1b6bc3780c7a62c7480b58bd34adad
parentfe2656af75fc1f42eadd489aefbed7f2d254c318 (diff)
downloadaur-python2-readability-lxml.tar.gz
bumped version
changed upstream url switched md5sum to sha256 fixed readme name added optimization flag
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0d2d72afbcb..5765d5e474b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python2-readability-lxml
pkgdesc = This is a python port of a ruby port of arc90’s readability project
- pkgver = 0.6.1
+ pkgver = 0.7
pkgrel = 1
- url = https://github.com/buriy/python-readability
+ url = https://pypi.org/project/readability-lxml/
arch = any
license = custom:Apache
depends = python2
depends = python2-chardet
depends = python2-cssselect
depends = python2-lxml
- source = https://pypi.python.org/packages/source/r/readability-lxml/readability-lxml-0.6.1.tar.gz
+ source = https://pypi.python.org/packages/source/r/readability-lxml/readability-lxml-0.7.tar.gz
source = LICENSE
- md5sums = ba7bd3b90f2689472df0b10cc87ad5f2
- md5sums = 180667c7abbe3fa664518bfc5da9a145
+ sha256sums = b6b30684e302802cdab490dc5093555bfebba663eb569814225939c6b0dead3f
+ sha256sums = 1f2afa61a3e7d62e5cf62b471c60c40853effc3428289f5961c84e24cf60447a
pkgname = python2-readability-lxml
diff --git a/PKGBUILD b/PKGBUILD
index 054d317fdc08..0e2ade16473f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: BrainDamage
pkgname=python2-readability-lxml
-pkgver=0.6.1
+pkgver=0.7
pkgrel=1
pkgdesc="This is a python port of a ruby port of arc90’s readability project"
arch=(any)
-url="https://github.com/buriy/python-readability"
+url="https://pypi.org/project/readability-lxml/"
license=("custom:Apache")
depends=("python2" "python2-chardet" "python2-cssselect" "python2-lxml")
-optdepends=()
-md5sums=("ba7bd3b90f2689472df0b10cc87ad5f2" "180667c7abbe3fa664518bfc5da9a145")
+sha256sums=("b6b30684e302802cdab490dc5093555bfebba663eb569814225939c6b0dead3f" "1f2afa61a3e7d62e5cf62b471c60c40853effc3428289f5961c84e24cf60447a")
source=("https://pypi.python.org/packages/source/r/readability-lxml/readability-lxml-$pkgver.tar.gz" "LICENSE")
-
build() {
cd "$srcdir/readability-lxml-$pkgver"
python2 setup.py build
@@ -19,6 +17,6 @@ build() {
package() {
install -m644 -D LICENSE "$pkgdir/usr/share/licenses/python2-readability-lxml/LICENSE"
cd "$srcdir/readability-lxml-$pkgver"
- python2 setup.py install --root="$pkgdir/" --prefix="/usr"
- install -m644 -D README "$pkgdir/usr/share/doc/python2-readability-lxml/README"
+ python2 setup.py install --optimize=1 --root="$pkgdir/" --prefix="/usr"
+ install -m644 -D README.rst "$pkgdir/usr/share/doc/python2-readability-lxml/README.rst"
}