summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Tryfonidis2015-06-27 16:30:04 +0300
committerTom Tryfonidis2015-06-27 16:30:04 +0300
commit07660558dfef481c4a9be45c06818ceff847d286 (patch)
tree6f5b43c6176c0de3a597bc7458d551a1b14f1cd2
downloadaur-07660558dfef481c4a9be45c06818ceff847d286.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8ac35efc9ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-requestbuilder
+ pkgdesc = Command line-driven HTTP request builder.
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/boto/requestbuilder
+ arch = any
+ license = ISC
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-six
+ depends = python2-requests
+ source = https://pypi.python.org/packages/source/r/requestbuilder/requestbuilder-0.2.3.tar.gz
+ md5sums = 3d9793e3a3b3dad23a8475e0480581db
+
+pkgname = python2-requestbuilder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d12dd7d0dcfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tom Tryfonidis <tomtryf@gmail.com>
+# Contributors: Tom Tryfonidis <tomtryf@gmail.com>
+
+pkgname=python2-requestbuilder
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Command line-driven HTTP request builder."
+arch=('any')
+url=https://github.com/boto/requestbuilder
+license=(ISC)
+depends=('python2' 'python2-six' 'python2-requests')
+makedepends=('python2-setuptools')
+source=(https://pypi.python.org/packages/source/r/requestbuilder/requestbuilder-$pkgver.tar.gz)
+md5sums=('3d9793e3a3b3dad23a8475e0480581db')
+
+build() {
+ cd "$srcdir/requestbuilder-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/requestbuilder-$pkgver"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}