summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2015-12-04 16:25:17 +0100
committerCedric Girard2015-12-04 16:25:17 +0100
commitda1fbb7342aad3638053aafac9cd451cd59bd4bd (patch)
tree637832e5425b253611508bfb1ef87f156e48fd40
parent3de0e75d6900d0c92dcec8c9a89e16ca52055294 (diff)
downloadaur-da1fbb7342aad3638053aafac9cd451cd59bd4bd.tar.gz
update patch file and deps
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--certs.patch22
3 files changed, 22 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffaaff924ad6..98f46490e84f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Dec 4 15:25:14 UTC 2015
pkgbase = python2-requests-git
pkgdesc = Python HTTP for Humans.
- pkgver = v2.3.0.41.gfcb735f
+ pkgver = v2.8.1.59.g40ce366
pkgrel = 1
url = http://python-requests.org
arch = any
@@ -8,6 +10,9 @@ pkgbase = python2-requests-git
makedepends = git
makedepends = python2-distribute
depends = python2
+ depends = python2-pyopenssl
+ depends = python2-ndg-httpsclient
+ depends = python2-pyasn1
optdepends = python2-certifi: SSL support
optdepends = python2-grequests: asynchronous requests with gevent
optdepends = python2-simplejson
@@ -16,7 +21,7 @@ pkgbase = python2-requests-git
source = requests::git+https://github.com/kennethreitz/requests.git
source = certs.patch
sha256sums = SKIP
- sha256sums = 482fc40ba146d2200771a690b3bedf6eddc9c3224d6f7b5ba529124039b07246
+ sha256sums = db84c6224f77bbf55c49bd69db71a98b3798f1d3275d7079861e1fbade8cc03f
pkgname = python2-requests-git
diff --git a/PKGBUILD b/PKGBUILD
index a2fbaf15ce83..357626ffd361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
pkgname=python2-requests-git
-pkgver=v2.3.0.41.gfcb735f
+pkgver=v2.8.1.59.g40ce366
pkgrel=1
_libname=${pkgname/python2-/}
pkgdesc="Python HTTP for Humans."
@@ -11,7 +11,7 @@ makedepends=('git' 'python2-distribute')
optdepends=('python2-certifi: SSL support'
'python2-grequests: asynchronous requests with gevent'
'python2-simplejson')
-depends=('python2')
+depends=('python2' 'python2-pyopenssl' 'python2-ndg-httpsclient' 'python2-pyasn1')
provides=('python2-requests')
license=('custom: ISC')
arch=('any')
@@ -20,8 +20,7 @@ source=('requests::git+https://github.com/kennethreitz/requests.git'
certs.patch
)
sha256sums=('SKIP'
- '482fc40ba146d2200771a690b3bedf6eddc9c3224d6f7b5ba529124039b07246'
-)
+ 'db84c6224f77bbf55c49bd69db71a98b3798f1d3275d7079861e1fbade8cc03f')
pkgver() {
cd "$srcdir"/requests
diff --git a/certs.patch b/certs.patch
index c428c8b6f038..69d27be85abf 100644
--- a/certs.patch
+++ b/certs.patch
@@ -1,17 +1,19 @@
---- requests/certs.py 2013-02-06 22:16:59.811389080 +0100
-+++ requests/certs.py.diff 2013-02-06 22:20:07.051490687 +0100
-@@ -12,13 +12,11 @@
+--- requests/certs.py.orig 2015-12-04 16:16:33.773055294 +0100
++++ requests/certs.py 2015-12-04 16:20:30.106729891 +0100
+@@ -11,7 +11,6 @@
+ environment, you can change the definition of where() to return a separately
packaged CA bundle.
"""
-
-import os.path
--
- def where():
- """Return the preferred certificate bundle."""
- # vendored bundle inside Requests
-- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+ return "/etc/ssl/certs/ca-certificates.crt"
+ try:
+ from certifi import where
+@@ -19,7 +18,7 @@
+ def where():
+ """Return the preferred certificate bundle."""
+ # vendored bundle inside Requests
+- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++ return "/etc/ssl/certs/ca-certificates.crt"
if __name__ == '__main__':
print(where())