summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Leahy2016-06-30 23:49:50 +0100
committerJoshua Leahy2016-06-30 23:49:50 +0100
commit24361dab173d3303da63b32ac567d7b05aec110d (patch)
treedc8733f92457cbe73ead628de11724efa7cedf5b
downloadaur-24361dab173d3303da63b32ac567d7b05aec110d.tar.gz
Initial commit (v1.3.5)
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD26
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edd97b03ef26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-requests-negotiate
+ pkgdesc = Negotiate authentication for the requests HTTP client library
+ pkgver = 1.3.5
+ pkgrel = 1
+ url = https://github.com/ox-it/requests-negotiate
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-requests
+ depends = python2-www-authenticate
+ depends = python2-gssapi
+ source = https://pypi.python.org/packages/fa/b8/d42bf2a1f759064fc68193fd810eb68e5a058d827c627d67caecfc992d24/requests-negotiate-1.3.5.tar.gz
+ source = LICENSE
+ md5sums = c367e991785519c22a90b36a6722bbb7
+ md5sums = 51ec989993f192a55975cc94a1560c01
+
+pkgname = python2-requests-negotiate
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4ba3dfa624ba
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2014, University of Oxford
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the University of Oxford nor the names of its
+ contributors may be used to endorse or promote products derived from this
+ software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE UNIVERSITY OF OXFORD BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b5144fd5f01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Joshua Leahy <jleahy@gmail.com>
+
+pkgname=python2-requests-negotiate
+pkgver=1.3.5
+pkgrel=1
+pkgdesc='Negotiate authentication for the requests HTTP client library'
+arch=(any)
+url='https://github.com/ox-it/requests-negotiate'
+license=('BSD')
+depends=('python2' 'python2-requests' 'python2-www-authenticate'
+'python2-gssapi')
+makedepends=('python2-setuptools')
+source=('https://pypi.python.org/packages/fa/b8/d42bf2a1f759064fc68193fd810eb68e5a058d827c627d67caecfc992d24/requests-negotiate-1.3.5.tar.gz' 'LICENSE')
+md5sums=('c367e991785519c22a90b36a6722bbb7' '51ec989993f192a55975cc94a1560c01')
+
+build() {
+ cd "${srcdir}/requests-negotiate-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/requests-negotiate-${pkgver}"
+ python2 setup.py install -O1 --skip-build --root="${pkgdir}"
+}
+