summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2016-12-13 15:00:13 -0500
committerXavierCLL2016-12-13 15:00:13 -0500
commit0d34db50d3f6fd41b21ca7100eb2486a992029cf (patch)
treec19a67a540383a942dfbf8e689e7654e0b15677c
parentbd5c959dafb01dd061745aa82a8e7fe0619af360 (diff)
downloadaur-0d34db50d3f6fd41b21ca7100eb2486a992029cf.tar.gz
Updated version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 10 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe42cf595dfb..2b3e124c6b3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
# Generated by mksrcinfo v8
-# Tue Dec 13 17:31:15 UTC 2016
-pkgbase = python-rios
+# Tue Dec 13 20:00:04 UTC 2016
+pkgbase = python2-rios
pkgdesc = A set of Python modules which makes it easy to write raster processing code in Python. Built on top of GDAL.
pkgver = 1.4.3
pkgrel = 1
url = http://rioshome.org/
arch = any
license = GPLv3
+ depends = python2
+ depends = python2-numpy
+ depends = gdal
source = https://bitbucket.org/chchrsc/rios/downloads/rios-1.4.3.tar.gz
sha256sums = 2dfb4c4712e5182b49e92709d48a0ff79c89a8f1e2199aed9523de6c201600d8
-pkgname = python-rios
- depends = python
- depends = python-numpy
- depends = gdal
-
pkgname = python2-rios
- depends = python2
- depends = python2-numpy
- depends = gdal
diff --git a/PKGBUILD b/PKGBUILD
index 176a3b8febbb..5ae1258e9a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,22 @@
# Maintainer: XavierCLL
-pkgbase=python-rios
-pkgname=('python-rios' 'python2-rios')
+pkgname=python2-rios
pkgver=1.4.3
pkgrel=1
pkgdesc="A set of Python modules which makes it easy to write raster processing code in Python. Built on top of GDAL."
arch=('any')
url="http://rioshome.org/"
license=('GPLv3')
+depends=('python2' 'python2-numpy' 'gdal')
source=("https://bitbucket.org/chchrsc/rios/downloads/rios-$pkgver.tar.gz")
sha256sums=('2dfb4c4712e5182b49e92709d48a0ff79c89a8f1e2199aed9523de6c201600d8')
build() {
- cp -a ${srcdir}/rios-$pkgver ${srcdir}/rios-$pkgver-2
-
- cd ${srcdir}/rios-$pkgver/
- python setup.py build
-
- cd ${srcdir}/rios-$pkgver-2/
+ cd rios-$pkgver/
python2 setup.py build
}
-package_python-rios() {
- depends=('python' 'python-numpy' 'gdal')
- cd ${srcdir}/rios-$pkgver/
- python setup.py install --root="$pkgdir"
-}
-
-package_python2-rios() {
- depends=('python2' 'python2-numpy' 'gdal')
- cd ${srcdir}/rios-$pkgver-2/
+package() {
+ cd rios-$pkgver/
python2 setup.py install --root="$pkgdir"
}