summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit507137cf59d5e20650f21cc71ba49b9045d94b79 (patch)
tree82346e3abdbac3be9f5b174cfc5ce0f77e1082c0
downloadaur-507137cf59d5e20650f21cc71ba49b9045d94b79.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72a02ef8ddac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-rlp
+ pkgdesc = A package for encoding and decoding data in and from Recursive Length Prefix notation
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = https://github.com/ethereum/pyrlp
+ arch = any
+ groups = ethereum
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/r/rlp/rlp-0.3.8.tar.gz
+ md5sums = 89f23e2197bc70c82f48b81916947df5
+ sha256sums = 347b1bfbe585fe56c9b9ca98d440fbaeaa005200d49cb4df06c62434306d2a77
+
+pkgname = python2-rlp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33760fa8d080
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-rlp
+pkgver=0.3.8
+pkgrel=1
+pkgdesc="A package for encoding and decoding data in and from Recursive Length Prefix notation"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+groups=('ethereum')
+url="https://github.com/ethereum/pyrlp"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/r/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('89f23e2197bc70c82f48b81916947df5')
+sha256sums=('347b1bfbe585fe56c9b9ca98d440fbaeaa005200d49cb4df06c62434306d2a77')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg2 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg2 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}