summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron McDaniel2018-06-01 09:41:43 -0500
committerAaron McDaniel2018-06-01 09:41:43 -0500
commit4e7e4502ca3849186dbf65454b56c6a3ddf4351d (patch)
tree9dc11437c2bda81936c1b6eb4d7748a11214812d
downloadaur-4e7e4502ca3849186dbf65454b56c6a3ddf4351d.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD34
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..628e7c925a59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-ropgadget-git
+ pkgdesc = Search for gadgets in your binaries to facilitate ROP exploitation - Python2 library only
+ pkgver = 5.4.r74.g0dc14e7
+ pkgrel = 1
+ url = http://shell-storm.org/project/ROPgadget/
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-capstone
+ provides = python2-ropgadget-git
+ conflicts = python2-ropgadget-git
+ source = python2-ropgadget-git::git+https://github.com/JonathanSalwan/ROPgadget.git
+ md5sums = SKIP
+
+pkgname = python2-ropgadget-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e0a0923eef9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignored folders
+src/
+python2-ropgadget-git/
+
+# Ignored files
+*.pkg.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2480a4a6f417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
+
+pkgname=python2-ropgadget-git
+pkgver=5.4.r74.g0dc14e7
+pkgrel=1
+pkgdesc='Search for gadgets in your binaries to facilitate ROP exploitation - Python2 library only'
+url='http://shell-storm.org/project/ROPgadget/'
+arch=('any')
+license=('GPL')
+depends=('python2' 'python2-capstone')
+makedepends=('git' 'python2-setuptools')
+optdepends=()
+backup=()
+source=("${pkgname}::git+https://github.com/JonathanSalwan/ROPgadget.git")
+md5sums=('SKIP')
+provides=('python2-ropgadget-git')
+conflicts=('python2-ropgadget-git')
+
+pkgver() {
+ cd "${pkgname}"
+ # Remove 'v' prefix on tags; prefix revision with 'r'; replace all '-' with '.'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${pkgname}"
+ python2 setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ rm -r "${pkgdir}/usr/bin" # Remove binaries
+}
+
+check() {
+ cd ${pkgname}/test-suite-binaries
+ #./test.sh
+}