summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:17:59 -0700
committerKartik Mohta2020-05-31 11:17:59 -0700
commit0d8718f4c43dee6d6a0602f655085ef3d7bfcb38 (patch)
tree7a2afb46d9d100bc3b4075eab85d43beebd0f812
parent827786f241e5b80b8ff01ecf1eed5565dc62b88c (diff)
downloadaur-0d8718f4c43dee6d6a0602f655085ef3d7bfcb38.tar.gz
Switch source to github repo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43ceef74d10..bde37e088410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python2-rosdistro
pkgdesc = A tool to work with rosdistro files
pkgver = 0.8.2
- pkgrel = 1
- url = http://wiki.ros.org/rosdistro
+ pkgrel = 2
+ url = https://github.com/ros-infrastructure/rosdistro
arch = any
license = BSD
makedepends = python2-setuptools
@@ -11,8 +11,8 @@ pkgbase = python2-rosdistro
depends = python2-rospkg
depends = python2-yaml
conflicts = python-rosdistro
- source = https://files.pythonhosted.org/packages/source/r/rosdistro/rosdistro-0.8.2.tar.gz
- sha256sums = aa51e08e27e59dfd26c7754dc43fb3e99f897fd9281ff64a86723b264fcbd964
+ source = https://github.com/ros-infrastructure/rosdistro/archive/0.8.2.tar.gz
+ sha256sums = ca6e7955820658781bde572927895c2ae8d89c37d5d891a254fd9cc29f9904a6
pkgname = python2-rosdistro
diff --git a/PKGBUILD b/PKGBUILD
index 3b91918696ca..642cf507ceb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python2-rosdistro'
pkgname=('python2-rosdistro')
-_module='rosdistro'
pkgver='0.8.2'
-pkgrel=1
-pkgdesc="A tool to work with rosdistro files"
-url="http://wiki.ros.org/rosdistro"
+pkgrel=2
+pkgdesc='A tool to work with rosdistro files'
+arch=('any')
+url='https://github.com/ros-infrastructure/rosdistro'
+license=('BSD')
depends=('python2' 'python2-catkin_pkg' 'python2-rospkg' 'python2-yaml')
-conflicts=('python-rosdistro')
makedepends=('python2-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('aa51e08e27e59dfd26c7754dc43fb3e99f897fd9281ff64a86723b264fcbd964')
+
+conflicts=('python-rosdistro')
+source=("https://github.com/ros-infrastructure/rosdistro/archive/${pkgver}.tar.gz")
+sha256sums=('ca6e7955820658781bde572927895c2ae8d89c37d5d891a254fd9cc29f9904a6')
+
+_module='rosdistro'
build() {
cd "${srcdir}/${_module}-${pkgver}"