summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDJ Lucas2015-12-06 01:22:06 -0600
committerDJ Lucas2015-12-06 01:22:06 -0600
commitd32fb786a72aa0c09e79d1c7cbcb7f363ed06e89 (patch)
treeeb09a9a2eefc52bb79def149ad1ca4e08e5b60f6
downloadaur-d32fb786a72aa0c09e79d1c7cbcb7f363ed06e89.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..349f578a4df4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Dec 6 07:21:50 UTC 2015
+pkgbase = python2-rpclib
+ pkgdesc = A transport and architecture agnostic rpc (de)serialization library that focuses on making small, rpc-oriented messaging work
+ pkgver = 2.8.0
+ pkgrel = 2
+ url = http://github.com/arskom/rpclib
+ arch = any
+ license = LGPL
+ depends = python2-pytz
+ depends = python2-lxml
+ optdepends = mod_wsgi
+ source = https://pypi.python.org/packages/source/r/rpclib/rpclib-2.8.0-rc.tar.gz
+ sha256sums = 846d46bc6ffff23a3c8382df45dce5ac2e7d889ce1904d2b394864d21cf329c1
+
+pkgname = python2-rpclib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1787e52d499
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: DJ Lucas <dj_AT_linuxfromscratch_DOT_org>
+pkgname=python2-rpclib
+_pkgname=rpclib
+pkgver=2.8.0
+pkgrel=2
+pkgdesc="A transport and architecture agnostic rpc (de)serialization library that focuses on making small, rpc-oriented messaging work"
+arch=('any')
+url="http://github.com/arskom/rpclib"
+license=('LGPL')
+depends=('python2-pytz' 'python2-lxml')
+optdepends=('mod_wsgi')
+source=(https://pypi.python.org/packages/source/r/${_pkgname}/${_pkgname}-${pkgver}-rc.tar.gz)
+sha256sums=('846d46bc6ffff23a3c8382df45dce5ac2e7d889ce1904d2b394864d21cf329c1')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}-rc
+ sed "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -i rpclib/test/sort_wsdl.py
+ sed "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -i $(find . -name '*.py')
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}-rc
+ python2 setup.py install --root=${pkgdir}/
+}