summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Johnson2015-07-05 23:44:26 -0500
committerErik Johnson2015-07-05 23:44:26 -0500
commitf49db567a8e5633eda4fc92efbfd45b6b3a13e0a (patch)
tree81a995c96139acc40b1a09fb9eb76e7e179d18b1
downloadaur-f49db567a8e5633eda4fc92efbfd45b6b3a13e0a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca817411bf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-rtkit
+ pkgdesc = Best Practical RT (Request Tracker) data access python module for REST interface.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/python-rtkit/
+ arch = any
+ license = Apache
+ makedepends = python2-distribute
+ depends = python2
+ source = http://pypi.python.org/packages/source/p/python-rtkit/python-rtkit-0.2.1.tar.gz
+ md5sums = ff84c4d586eaa8111bae1807025e60b3
+
+pkgname = python2-rtkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e515cd6b678
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Erik Johnson <palehose at gmail dot com>
+pkgname=python2-rtkit
+_realname=python-rtkit
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Best Practical RT (Request Tracker) data access python module for REST interface."
+arch=('any')
+url="http://pypi.python.org/pypi/${_realname}/"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-distribute')
+source=("http://pypi.python.org/packages/source/p/${_realname}/${_realname}-${pkgver}.tar.gz")
+md5sums=('ff84c4d586eaa8111bae1807025e60b3')
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" -O1
+}
+
+# vim:set ts=2 sw=2 et: