summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2016-02-13 22:38:58 +0100
committerJake2016-02-13 22:38:58 +0100
commit58a5db700c2dbe02f05fb37ba528e4d3ddff3905 (patch)
tree1b944d5a2e13a3f018019050a406f163fb75f9ca
downloadaur-58a5db700c2dbe02f05fb37ba528e4d3ddff3905.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cbf56f33b5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Feb 13 21:34:27 UTC 2016
+pkgbase = python2-rtree
+ pkgdesc = Python wrapper of libspatialindex
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = http://toblerity.github.com/rtree/
+ arch = any
+ license = LGPL2.1
+ makedepends = python2-setuptools
+ makedepends = libspatialindex-git
+ source = https://pypi.python.org/packages/source/R/Rtree/Rtree-0.8.2.tar.gz
+ sha256sums = 064ecd9791fe170a8492f4ae75b0cbe8e62b5392f136a159a24d1b70c86d3c3f
+
+pkgname = python2-rtree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a35a4c285b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jake <ja.ke@posteo.de>
+
+pkgname=('python2-rtree')
+_pyname=Rtree
+pkgver=0.8.2
+pkgrel=1
+pkgdesc='Python wrapper of libspatialindex'
+url='http://toblerity.github.com/rtree/'
+arch=('any')
+license=('LGPL2.1')
+makedepends=('python2-setuptools' 'libspatialindex-git')
+source=("https://pypi.python.org/packages/source/R/Rtree/Rtree-${pkgver}.tar.gz")
+sha256sums=('064ecd9791fe170a8492f4ae75b0cbe8e62b5392f136a159a24d1b70c86d3c3f')
+
+
+package() {
+ cd "$srcdir/$_pyname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file