summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Ruijl2017-04-09 20:38:33 +0200
committerBen Ruijl2017-04-09 20:38:33 +0200
commit752d70382930ed2978474c407e50615e58938ac6 (patch)
tree37a6be8c6d97f97532dc26ef91e6b192f6b76142
downloadaur-752d70382930ed2978474c407e50615e58938ac6.tar.gz
First version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62155bd8dd93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-sabyenc
+ pkgdesc = Python2 yEnc package optimized for use within SABnzbd
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://github.com/sabnzbd/sabyenc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ source = https://github.com/sabnzbd/sabyenc/archive/v3.0.2.tar.gz
+ md5sums = 49684574e411ee36cc96e8b70aa99ad9
+
+pkgname = python2-sabyenc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d6c73c58e40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ben Ruijl <benruyl@gmail.com>
+
+pkgname=python2-sabyenc
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Python2 yEnc package optimized for use within SABnzbd"
+url="https://github.com/sabnzbd/sabyenc"
+arch=('i686' 'x86_64')
+license=("GPL")
+depends=("python2")
+
+source=("https://github.com/sabnzbd/sabyenc/archive/v${pkgver}.tar.gz")
+md5sums=('49684574e411ee36cc96e8b70aa99ad9')
+
+build() {
+ cd "${srcdir}/sabyenc-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/sabyenc-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+} \ No newline at end of file