summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-06-08 08:59:49 -0400
committerAdam Goldsmith2015-06-08 08:59:49 -0400
commit9f1898855703e1fca59d9adffd1858dab1fabf51 (patch)
tree05796a50bcc4ba981cbea6d019377aa02d71f311
downloadaur-9f1898855703e1fca59d9adffd1858dab1fabf51.tar.gz
migrating to AUR4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7949e8814f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-sarge-git
+ pkgdesc = The sarge package provides a wrapper for subprocess which provides command pipeline functionality.
+ pkgver = r133.b624f40f62a9
+ pkgrel = 1
+ url = https://bitbucket.org/vinay.sajip/sarge
+ arch = any
+ license = GPL
+ makedepends = mercurial
+ depends = python2
+ provides = python2-sarge
+ conflicts = python2-sarge
+ source = hg+https://bitbucket.org/vinay.sajip/sarge
+ md5sums = SKIP
+
+pkgname = python2-sarge-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc624b7ad183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adam Goldsmith <adam@adamgoldsmith.name>
+pkgname=python2-sarge-git
+pkgver=r133.b624f40f62a9
+pkgrel=1
+pkgdesc="The sarge package provides a wrapper for subprocess which provides command pipeline functionality."
+arch=('any')
+url="https://bitbucket.org/vinay.sajip/sarge"
+license=('GPL')
+makedepends=('mercurial')
+depends=(python2)
+provides=(python2-sarge)
+conflicts=(python2-sarge)
+source=('hg+https://bitbucket.org/vinay.sajip/sarge')
+md5sums=('SKIP')
+
+pkgver() {
+ cd sarge
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+package() {
+ cd "$srcdir/sarge"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: