summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-06-13 16:47:34 -0300
committerDanilo J. S. Bellini2022-06-13 16:47:34 -0300
commitf74c9894fffdbbe602c27c8fa35a991ab17c58df (patch)
tree6c3b4fedfae5d5acb17109071803edd62044d315
parent324f9840330ed97368bd4ddde985758f66b43f23 (diff)
downloadaur-f74c9894fffdbbe602c27c8fa35a991ab17c58df.tar.gz
Avoid testing "mess" and add Felix (v1.10.0-5)
The test runner was messing with the sys.path for tweaking the import mechanism, and it wasn't cleaning the perhaps incomplete testing data directory (test/testdir) before running the tests; these were replaced by a cleaning step and the standard unittest discovery approach Felix was the maintainer of this package in the community repository
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f1954cd0efa..27b075ce8014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-scandir
pkgdesc = Better directory iterator and faster os.walk() alternative
pkgver = 1.10.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/benhoyt/scandir
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index efd836bcf2bc..ed1aeaeb9e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=python2-scandir
_name=${pkgname#python2-}
pkgver=1.10.0
-pkgrel=4
+pkgrel=5
pkgdesc='Better directory iterator and faster os.walk() alternative'
arch=('x86_64')
url='https://github.com/benhoyt/scandir'
@@ -19,7 +20,9 @@ build() {
check() {
cd "$srcdir/$_name-$pkgver"
- LC_CTYPE=en_US.UTF-8 python2 test/run_tests.py
+ touch test/__init__.py
+ rm -rf test/testdir
+ LC_CTYPE=en_US.UTF-8 python2 -m unittest discover -v
}
package() {