summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit0b4358d517b2ff2dbd893a93cb916ba0c8dfa25d (patch)
treeaf1be554003c47526c49b68facf2f41bce6756e4
downloadaur-0b4358d517b2ff2dbd893a93cb916ba0c8dfa25d.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bddb875a2b92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-securestring
+ pkgdesc = Clears the contents of strings containing cryptographic material
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/dnet/pysecstr
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/S/SecureString/SecureString-0.1.tar.gz
+ source = https://pypi.python.org/packages/source/S/SecureString/SecureString-0.1.tar.gz.asc
+ md5sums = c84ac003a0e1dad96d80fa696ccb96fc
+ md5sums = 6f3ed918802f91508a0b708ebdfe4fc4
+ sha256sums = 46b5c3b2be2e7cbee81be8964596fad9150a581daabab20dbfe785e186607b3c
+ sha256sums = 823954eadef1387fbfcadee9346c821b569c128f09f18b78a19669ae10bfd167
+
+pkgname = python2-securestring
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..057662d7aac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-securestring
+_pipname=SecureString
+pkgver=0.1
+pkgrel=1
+pkgdesc="Clears the contents of strings containing cryptographic material"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://github.com/dnet/pysecstr"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/S/$_pipname/$_pipname-$pkgver.tar.gz
+ https://pypi.python.org/packages/source/S/$_pipname/$_pipname-$pkgver.tar.gz.asc)
+md5sums=('c84ac003a0e1dad96d80fa696ccb96fc'
+ '6f3ed918802f91508a0b708ebdfe4fc4')
+sha256sums=('46b5c3b2be2e7cbee81be8964596fad9150a581daabab20dbfe785e186607b3c'
+ '823954eadef1387fbfcadee9346c821b569c128f09f18b78a19669ae10bfd167')
+validpgpkeys=('278F163FABB0EFE41289BAA07559181E94176CCC')
+
+build() {
+ cd "$srcdir/$_pipname-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pipname-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}