summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:15:40 +0300
committerAchilleas Pipinellis2015-06-10 09:15:40 +0300
commit693a7d827d18af3448bbea739ddd3d7e7f04a8a7 (patch)
treec51a18b04951280b0c337b4fa408a621608196a2
downloadaur-693a7d827d18af3448bbea739ddd3d7e7f04a8a7.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93cc5617c439
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-sendfile
+ pkgdesc = A Python interface to sendfile(2)
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/giampaolo/pysendfile
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ source = https://pypi.python.org/packages/source/p/pysendfile/pysendfile-2.0.1.tar.gz
+ md5sums = e7b301eddd703ab74a48c59a8fda1f97
+
+pkgname = python2-sendfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7037d0c0e519
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer : Axilleas Pipinellis <axilleas@archlinux.info>
+
+_pkgname=pysendfile
+pkgname=python2-sendfile
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A Python interface to sendfile(2)"
+url="https://github.com/giampaolo/pysendfile"
+license=('MIT')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('python2')
+makedepends=('python2-distribute')
+source=("https://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz")
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir --optimize=1
+ }
+
+# vim:set ts=2 sw=2 et
+md5sums=('e7b301eddd703ab74a48c59a8fda1f97')