summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2018-06-28 20:29:36 +0200
committerGabriel Souza Franco2018-06-28 20:29:36 +0200
commitfb1d828afee5bac5e9f6b2bea7b7971a656af1f7 (patch)
tree14ce93e199e48fd3fa7773a9b82c7f79a5f11c9a
downloadaur-fb1d828afee5bac5e9f6b2bea7b7971a656af1f7.tar.gz
Re-add dropped package needed for freecad
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a60887362a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-shiboken2
+ pkgdesc = Generates bindings for C++ libraries using CPython source code
+ pkgver = 5.11.0
+ pkgrel = 2
+ url = http://qt-project.org/
+ arch = x86_64
+ license = GPL2
+ license = LGPL
+ makedepends = clang
+ makedepends = llvm
+ makedepends = cmake
+ makedepends = libxslt
+ makedepends = qt5-xmlpatterns
+ depends = python2
+ source = http://download.qt.io/official_releases/QtForPython/pyside2/PySide2-5.11.0-src/pyside-setup-everywhere-src-5.11.0.tar.xz
+ sha256sums = fbc412c4544bca308291a08a5173a949ca530d801f00b8337902a5067e490922
+
+pkgname = python2-shiboken2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a482fd1a6db9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pyside-setup-*
+*pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1d453b8185e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gabriel Souza Franco <Z2FicmllbGZyYW5jb3NvdXphQGdtYWlsLmNvbQ==>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python2-shiboken2
+_qtver=5.11.0
+pkgver=${_qtver/-/}
+pkgrel=2
+arch=(x86_64)
+url='http://qt-project.org/'
+license=(GPL2 LGPL)
+pkgdesc='Generates bindings for C++ libraries using CPython source code'
+depends=(python2)
+makedepends=(clang llvm cmake libxslt qt5-xmlpatterns)
+_pkgfqn=pyside-setup-everywhere-src-${_qtver}
+source=("http://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz")
+sha256sums=('fbc412c4544bca308291a08a5173a949ca530d801f00b8337902a5067e490922')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../${_pkgfqn}/sources/shiboken2 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=2
+ make
+}
+
+package_python2-shiboken2() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ # Provided in shiboken
+ rm -r "$pkgdir"/usr/{bin,include,lib/{cmake/*/Shiboken2Config{,Version}.cmake,pkgconfig},share}
+}