summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2015-08-05 23:43:04 -0400
committerDavid Parrish2015-08-05 23:43:04 -0400
commit0f6b468ed6007a5b39c0b9081b3d8deece379b4b (patch)
tree88a8808f99984d7bdf9d0e78ed4cf6668324388c
downloadaur-0f6b468ed6007a5b39c0b9081b3d8deece379b4b.tar.gz
Initial checkin
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD31
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffb6ab1e3ee2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-simple-crypt
+ pkgdesc = Simple, secure encryption and decryption for Python 2.7
+ pkgver = 4.1.7
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/simple-crypt
+ arch = any
+ license = custom
+ makedepends = python-distribute
+ depends = python-crypto
+ source = https://pypi.python.org/packages/source/s/simple-crypt/simple-crypt-4.1.7.tar.gz
+ source = LICENSE
+ md5sums = dc2b13ce6be9c9da08fb1e7d83498882
+ md5sums = e6208ad8f3763a8fd68f263ca0363732
+
+pkgname = python2-simple-crypt
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1661eb471352
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+(c) 2012-2015 Andrew Cooke, andrew@acooke.org; 2013 d10n, david@bitinvert.com. Released into the public domain for any use, but with absolutely no warranty.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e4bf2b739e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: David Parrish <daveparrish@gmail.com>
+
+pkgname=python2-simple-crypt
+pkgver=4.1.7
+pkgrel=1
+arch=('any')
+license=('custom')
+pkgdesc="Simple, secure encryption and decryption for Python 2.7"
+url="https://pypi.python.org/pypi/simple-crypt"
+makedepends=('python-distribute')
+depends=('python-crypto')
+source=("https://pypi.python.org/packages/source/s/simple-crypt/simple-crypt-$pkgver.tar.gz"
+ "LICENSE")
+md5sums=('dc2b13ce6be9c9da08fb1e7d83498882'
+ 'e6208ad8f3763a8fd68f263ca0363732')
+
+build() {
+ cd "$srcdir/simple-crypt-$pkgver"
+ ls
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"
+ ls
+ # Install public domain license
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cd "simple-crypt-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1
+}