summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2019-05-16 20:40:56 -0400
committerDavid Parrish2019-05-16 20:40:56 -0400
commitf9aee0c24cf6aaa6262d491475eb0b9a7c4c8b6f (patch)
tree00ad30ba22f11266b230d8287a3ad17cd6a13426
parent0f6b468ed6007a5b39c0b9081b3d8deece379b4b (diff)
downloadaur-f9aee0c24cf6aaa6262d491475eb0b9a7c4c8b6f.tar.gz
Add python2 dependency and apply namcap suggestions
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffb6ab1e3ee2..ce7c784ea45e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = python2-simple-crypt
arch = any
license = custom
makedepends = python-distribute
+ makedepends = python2
depends = python-crypto
source = https://pypi.python.org/packages/source/s/simple-crypt/simple-crypt-4.1.7.tar.gz
source = LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 6e4bf2b739e5..c94856c2f0d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('any')
license=('custom')
pkgdesc="Simple, secure encryption and decryption for Python 2.7"
url="https://pypi.python.org/pypi/simple-crypt"
-makedepends=('python-distribute')
+makedepends=('python-distribute' 'python2')
depends=('python-crypto')
source=("https://pypi.python.org/packages/source/s/simple-crypt/simple-crypt-$pkgver.tar.gz"
"LICENSE")
@@ -15,17 +15,17 @@ md5sums=('dc2b13ce6be9c9da08fb1e7d83498882'
'e6208ad8f3763a8fd68f263ca0363732')
build() {
- cd "$srcdir/simple-crypt-$pkgver"
+ cd "$srcdir/simple-crypt-$pkgver" || exit
ls
python2 setup.py build
}
package() {
- cd "$srcdir"
+ cd "$srcdir" || exit
ls
# Install public domain license
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
- cd "simple-crypt-$pkgver"
- python2 setup.py install --root=$pkgdir --optimize=1
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cd "simple-crypt-$pkgver" || exit
+ python2 setup.py install --root="$pkgdir" --optimize=1
}