summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2021-02-28 14:32:27 -0500
committerEli Schwartz2021-02-28 14:32:27 -0500
commitebeb275fc19d85ff70c3c1e7c69b2d54309b5d8a (patch)
tree8d0891f96931c2296ac7f5a612b7d38009ba409a
downloadaur-ebeb275fc19d85ff70c3c1e7c69b2d54309b5d8a.tar.gz
import from community
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7362526ad3b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-simplejson
+ pkgdesc = Simple, fast, extensible JSON encoder/decoder for python2
+ pkgver = 3.17.2
+ pkgrel = 4
+ url = https://github.com/simplejson/simplejson
+ arch = x86_64
+ license = MIT
+ checkdepends = python2-pytest-runner
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-simplejson-3.17.2.tar.gz::https://github.com/simplejson/simplejson/archive/v3.17.2.tar.gz
+ sha512sums = 59428640d43fdc6927db752a36196f48d00818a87d924358deab7e498709515423ecdd34dece31364c5e8d64b63d99112fd4a4b8a03b9f9c6533268afc38e314
+
+pkgname = python2-simplejson
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8131611ec030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: David Moore <davidm@sjsoft.com>
+
+pkgname=python2-simplejson
+pkgver=3.17.2
+pkgrel=4
+pkgdesc='Simple, fast, extensible JSON encoder/decoder for python2'
+license=('MIT')
+arch=('x86_64')
+url='https://github.com/simplejson/simplejson'
+depends=('python2')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha512sums=('59428640d43fdc6927db752a36196f48d00818a87d924358deab7e498709515423ecdd34dece31364c5e8d64b63d99112fd4a4b8a03b9f9c6533268afc38e314')
+
+build() {
+ cd "${srcdir}"/simplejson-${pkgver}
+
+ python2 setup.py build
+}
+
+check() {
+ cd "${srcdir}"/simplejson-${pkgver}
+
+ python2 setup.py pytest
+}
+
+package_python2-simplejson() {
+ cd simplejson-${pkgver}
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}