summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-19 15:23:50 -0500
committerCarlos Aznarán Laos2022-03-19 15:23:50 -0500
commit3a912dc3a22a35eaf298babbd188de35dfbff893 (patch)
treeca582bc9705e9ba7706dadaf336a145309922817
parent1e1c852b2948a42e31f9d75f006861cdeb624bd8 (diff)
downloadaur-3a912dc3a22a35eaf298babbd188de35dfbff893.tar.gz
Bump version to 3.7.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
-rw-r--r--license19
4 files changed, 23 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09a9c0f100b7..299a01ea63b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = python2-singledispatch
pkgdesc = Implementation of functools.singledispatch from Python 3.4
- pkgver = 3.4.0.3
- pkgrel = 4
- url = https://bitbucket.org/ambv/singledispatch
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = https://github.com/jaraco/singledispatch
arch = any
license = MIT
makedepends = python2-setuptools
- depends = python2
depends = python2-six
- source = https://pypi.python.org/packages/source/s/singledispatch/singledispatch-3.4.0.3.tar.gz
- source = license
- md5sums = af2fc6a3d6cc5a02d0bf54d909785fcb
- md5sums = 360faaffcf297a20e20e2289af00ce07
+ source = https://github.com/jaraco/singledispatch/archive/v3.7.0.tar.gz
+ sha512sums = 0ec8503c188dd095eaab6e07147aad8dc7863c51d746fbc19086fb434ca1a48c65fa2219110f3d530a8370242f6df72e59fbf451ec4ce7ba49b751fb5c097c34
pkgname = python2-singledispatch
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index ad33dbc3d3de..385181175ed8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,30 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
-
-pkgname=python2-singledispatch
-pkgver=3.4.0.3
-pkgrel=4
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+_base=singledispatch
+pkgname=python2-${_base}
+pkgver=3.7.0
+pkgrel=1
pkgdesc="Implementation of functools.singledispatch from Python 3.4"
-arch=('any')
-url="https://bitbucket.org/ambv/singledispatch"
-license=('MIT')
-depends=('python2' 'python2-six')
-makedepends=('python2-setuptools')
-source=("https://pypi.python.org/packages/source/s/singledispatch/singledispatch-$pkgver.tar.gz" license)
-md5sums=('af2fc6a3d6cc5a02d0bf54d909785fcb'
- '360faaffcf297a20e20e2289af00ce07')
+arch=(any)
+url="https://github.com/jaraco/singledispatch"
+license=(MIT)
+depends=(python2-six)
+makedepends=(python2-setuptools)
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('0ec8503c188dd095eaab6e07147aad8dc7863c51d746fbc19086fb434ca1a48c65fa2219110f3d530a8370242f6df72e59fbf451ec4ce7ba49b751fb5c097c34')
prepare() {
- cd "${srcdir}"/singledispatch-$pkgver
-
+ cd ${_base}-${pkgver}
sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
$(find "${srcdir}" -name '*.py')
}
build() {
- cd "${srcdir}"/singledispatch-$pkgver
-
+ cd ${_base}-${pkgver}
python2 setup.py build
}
package() {
- cd "${srcdir}"/singledispatch-$pkgver
-
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
-
- install -D "${srcdir}"/license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
diff --git a/license b/license
deleted file mode 100644
index 4ebb526b90ae..000000000000
--- a/license
+++ /dev/null
@@ -1,19 +0,0 @@
-Copyright (c) 2013 Łukasz Langa
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.