summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2017-05-10 09:08:15 +0200
committerÓscar García Amor2017-05-10 09:08:15 +0200
commit156b3504e54c8ff9d45779953465a8f35d095621 (patch)
tree2ae7089746c24204f71eca54abb26e22a8b34ed3
parent9b0a747dcc6bc86935e7513361f75034ae93c91d (diff)
downloadaur-156b3504e54c8ff9d45779953465a8f35d095621.tar.gz
Use OpenSSL 1.0
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26af76210f98..e4fdeb6d8163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
_pkgname=python-sipsimple
pkgname=python2-sipsimple
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python SDK for development of SIP end-points"
license=('custom:MIT' 'LGPL')
arch=('i686' 'x86_64')
url="http://download.ag-projects.com/SipClient"
-depends=('alsa-lib' 'util-linux' 'python2-dateutil' 'cython2' 'python2-cjson'
+depends=('alsa-lib' 'util-linux' 'python2-dateutil' 'cython2' 'python2-cjson' 'openssl-1.0'
'python2-dnspython' 'python2-eventlib' 'python2-msrplib' 'python2-xcaplib' 'python2-otr-git' 'ffmpeg')
makedepends=('subversion' 'ffmpeg2.8')
options=('!makeflags')
@@ -24,6 +24,11 @@ build() {
# fix permissions
chmod 755 "${srcdir}/${_pkgname}-release-${pkgver}/deps/pjsip/configure"
chmod 755 "${srcdir}/${_pkgname}-release-${pkgver}/deps/pjsip/aconfigure"
+
+ # use openssl 1.0
+ export CFLAGS="-I/usr/include/openssl-1.0"
+ export LDFLAGS="-L/usr/lib/openssl-1.0"
+
# build
python2 setup.py build_ext --pjsip-clean-compile
}
@@ -36,4 +41,3 @@ package() {
install -Dm644 LICENSE \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-