summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2018-06-15 12:34:12 +0200
committerÓscar García Amor2018-06-15 12:34:12 +0200
commitdb07b8745dd5bd67d4f96ce1087bc83799c2d933 (patch)
treeb7e16a1eea0e05667a219e06097945fe9fd98935
parentd2265c2588323f1f0824714b3d8545a3eac602b2 (diff)
downloadaur-db07b8745dd5bd67d4f96ce1087bc83799c2d933.tar.gz
Added change_macro_name.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--change_macro_name.patch12
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b58d4c3fbda..fb2d497795d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-sipsimple
pkgdesc = Python SDK for development of SIP end-points
pkgver = 3.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://download.ag-projects.com/SipClient
arch = i686
arch = x86_64
@@ -22,7 +22,9 @@ pkgbase = python2-sipsimple
depends = ffmpeg
options = !makeflags
source = https://github.com/AGProjects/python-sipsimple/archive/release-3.1.1/python-sipsimple-3.1.1.tar.gz
+ source = change_macro_name.patch
sha256sums = b58936acc596761020d41a8b3e617a9240e74607d8f1d07d0e87cb28eebf206a
+ sha256sums = 11585933e86c4759610d9a303f96c80d3f3bc78548f6a682b0f4fb6fb6c06b4d
pkgname = python2-sipsimple
diff --git a/PKGBUILD b/PKGBUILD
index a554f80d8946..9ebc6205f83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
# Contributor: Ingo Gottwald <in dot gottwald at gmail dot com>
# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Shawn Nock <nock@nocko.se>
_pkgname=python-sipsimple
pkgname=python2-sipsimple
pkgver=3.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python SDK for development of SIP end-points"
license=('custom:MIT' 'LGPL')
arch=('i686' 'x86_64')
@@ -16,8 +17,15 @@ depends=('alsa-lib' 'util-linux' 'python2-dateutil' 'cython2' 'python2-cjson' 'o
'python2-dnspython' 'python2-eventlib' 'python2-msrplib' 'python2-xcaplib' 'python2-otr-git' 'ffmpeg')
makedepends=('ffmpeg2.8')
options=('!makeflags')
-source=("https://github.com/AGProjects/${_pkgname}/archive/release-${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('b58936acc596761020d41a8b3e617a9240e74607d8f1d07d0e87cb28eebf206a')
+source=("https://github.com/AGProjects/${_pkgname}/archive/release-${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "change_macro_name.patch")
+sha256sums=('b58936acc596761020d41a8b3e617a9240e74607d8f1d07d0e87cb28eebf206a'
+ '11585933e86c4759610d9a303f96c80d3f3bc78548f6a682b0f4fb6fb6c06b4d')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-release-${pkgver}"
+ patch -p1 < ../../change_macro_name.patch
+}
build() {
cd "${srcdir}/${_pkgname}-release-${pkgver}"
diff --git a/change_macro_name.patch b/change_macro_name.patch
new file mode 100644
index 000000000000..70d19bca98fb
--- /dev/null
+++ b/change_macro_name.patch
@@ -0,0 +1,12 @@
+diff -ura python-sipsimple-release-3.1.1/deps/pjsip/pjmedia/src/pjmedia-codec/ffmpeg_vid_codecs.c python-sipsimple-release-3.1.1.new/deps/pjsip/pjmedia/src/pjmedia-codec/ffmpeg_vid_codecs.c
+--- python-sipsimple-release-3.1.1/deps/pjsip/pjmedia/src/pjmedia-codec/ffmpeg_vid_codecs.c 2017-05-05 10:29:51.000000000 -0400
++++ python-sipsimple-release-3.1.1.new/deps/pjsip/pjmedia/src/pjmedia-codec/ffmpeg_vid_codecs.c 2018-06-15 05:25:58.085280922 -0400
+@@ -1689,7 +1689,7 @@
+ * Normally, encoded buffer is allocated more than needed, so lets just
+ * bzero the input buffer end/pad, hope it will be just fine.
+ */
+- pj_bzero(avpacket.data+avpacket.size, FF_INPUT_BUFFER_PADDING_SIZE);
++ pj_bzero(avpacket.data+avpacket.size, AV_INPUT_BUFFER_PADDING_SIZE);
+
+ output->bit_info = 0;
+ output->timestamp = input->timestamp;