summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-07-04 08:27:42 -0700
committerAndy Weidenbaum2015-07-04 08:27:42 -0700
commit2e7fa7a4b9ab25861184c307368cf1c5edf54fa1 (patch)
treefee981f4227ccc710d6d62b1a25d2b2f6c340b4e
parent46b14515b3a8e00426427c3f5dfb03bd8b58d4cf (diff)
downloadaur-2e7fa7a4b9ab25861184c307368cf1c5edf54fa1.tar.gz
update pkgver to 2.5.5, s/msg/msg2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5f72d10c998..b918a82b9354 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = python2-snakebite
pkgdesc = Pure Python HDFS client
- pkgver = 2.5.4
+ pkgver = 2.5.5
pkgrel = 1
url = https://github.com/spotify/snakebite
arch = any
license = Apache
makedepends = python2-setuptools
depends = python2
+ depends = python2-argparse
depends = python2-protobuf
provides = python2-snakebite
provides = snakebite
conflicts = snakebite
options = !emptydirs
- source = https://pypi.python.org/packages/source/s/snakebite/snakebite-2.5.4.tar.gz
- md5sums = 6ee92be030f5bea0042754b9f1c91bb4
- sha256sums = 7fc93a2abc74ebc94fa5bb104685fec2bdec66c21602b476335fe696c843506b
+ source = https://pypi.python.org/packages/source/s/snakebite/snakebite-2.5.5.tar.gz
+ md5sums = 3612ffa7ac7274bca31e8c8b693a4160
+ sha256sums = d19dc6221e1f7c94aca31897511ae4785ef624c3b510460b65ddd109b7f377c4
pkgname = python2-snakebite
diff --git a/PKGBUILD b/PKGBUILD
index bedd7b8bcf9a..59768a8d97b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,39 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=python2-snakebite
-pkgver=2.5.4
+pkgver=2.5.5
pkgrel=1
pkgdesc="Pure Python HDFS client"
arch=('any')
-depends=('python2' 'python2-protobuf')
+depends=('python2' 'python2-argparse' 'python2-protobuf')
makedepends=('python2-setuptools')
url="https://github.com/spotify/snakebite"
license=('Apache')
options=(!emptydirs)
source=(https://pypi.python.org/packages/source/s/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
-md5sums=('6ee92be030f5bea0042754b9f1c91bb4')
-sha256sums=('7fc93a2abc74ebc94fa5bb104685fec2bdec66c21602b476335fe696c843506b')
+md5sums=('3612ffa7ac7274bca31e8c8b693a4160')
+sha256sums=('d19dc6221e1f7c94aca31897511ae4785ef624c3b510460b65ddd109b7f377c4')
provides=('python2-snakebite' 'snakebite')
conflicts=('snakebite')
build() {
cd "$srcdir/${pkgname#python2-}-$pkgver"
- msg 'Building...'
+ msg2 'Building...'
python2 setup.py build
}
package() {
cd "$srcdir/${pkgname#python2-}-$pkgver"
- msg 'Installing...'
+ msg2 'Installing...'
python2 setup.py install --root="$pkgdir" --optimize=1
- msg 'Fixing LICENSE placement...'
+ msg2 'Fixing LICENSE placement...'
install -dm 755 "$pkgdir/usr/share/licenses/$pkgname"
mv "$pkgdir/usr/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
- msg 'Fixing bash-completion placement...'
+ msg2 'Fixing bash-completion placement...'
install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
mv "$pkgdir/usr/etc/bash_completion.d/snakebite-completion.bash" \
"$pkgdir/usr/share/bash-completion/completions/snakebite"