summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commita795118b4799b059bb6d69e059ab2022845072b2 (patch)
treeb7a670fbdef9bcbc27a9f2d00569605ab77bc5de
downloadaur-a795118b4799b059bb6d69e059ab2022845072b2.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d76e20fca64c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-socksipy-branch
+ pkgdesc = Allows you to create TCP connections through a SOCKS proxy without any special effort
+ pkgver = 1.01
+ pkgrel = 1
+ url = http://code.google.com/p/socksipy-branch/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/S/SocksiPy-branch/SocksiPy-branch-1.01.tar.gz
+ md5sums = a59e29647320211202ce79b0cf873106
+ sha256sums = 17a95060e28c3b9038a9b8c1865c54f8c1c5bef15d561bf777c9bbf3c80e8406
+
+pkgname = python2-socksipy-branch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e1111be76da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-socksipy-branch
+pkgver=1.01
+pkgrel=1
+pkgdesc="Allows you to create TCP connections through a SOCKS proxy without any special effort"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="http://code.google.com/p/socksipy-branch/"
+license=('BSD')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/S/SocksiPy-branch/SocksiPy-branch-$pkgver.tar.gz)
+md5sums=('a59e29647320211202ce79b0cf873106')
+sha256sums=('17a95060e28c3b9038a9b8c1865c54f8c1c5bef15d561bf777c9bbf3c80e8406')
+
+build() {
+ cd "$srcdir/SocksiPy-branch-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/SocksiPy-branch-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}