summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-11-28 19:35:45 +0100
committerfelics2018-11-28 19:35:45 +0100
commit4eeb69c4b0e31206f4861dcbca3691c138f975f1 (patch)
treeae495d5c0b9d367d513967e79b3d884411663b56
downloadaur-4eeb69c4b0e31206f4861dcbca3691c138f975f1.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6842e524f4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-socksipy-branch-1.01
+ pkgdesc = Version 1.01 of SocksiPy, for compatibility reasons.
+ pkgver = 1.01
+ pkgrel = 1
+ url = http://code.google.com/archive/p/socksipy-branch/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ provides = python2-socksipy=1.01
+ provides = python2-socksipy-branch=1.01
+ conflicts = python2-socksipy
+ conflicts = python2-socksipy-branch
+ options = !emptydirs
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/socksipy-branch/SocksiPy-branch-1.01.tar.gz
+ sha256sums = 8331732ed0fcacc84e7c33c07f5e3902f0869a215b3a56f0a8845d2fafbfd504
+
+pkgname = python2-socksipy-branch-1.01
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eefea2ddc36e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: dreieck
+# Contributor : Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: zoe <chp321 [at] gmail [dot] com>
+
+pkgname=python2-socksipy-branch-1.01
+pkgver=1.01
+pkgrel=1
+pkgdesc="Version 1.01 of SocksiPy, for compatibility reasons."
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+provides=("python2-socksipy=${pkgver}" "python2-socksipy-branch=${pkgver}")
+conflicts=("python2-socksipy" "python2-socksipy-branch")
+url="http://code.google.com/archive/p/socksipy-branch/"
+license=('BSD')
+options=(!emptydirs)
+source=(
+ "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/socksipy-branch/SocksiPy-branch-1.01.tar.gz"
+)
+
+sha256sums=(
+ '8331732ed0fcacc84e7c33c07f5e3902f0869a215b3a56f0a8845d2fafbfd504'
+)
+
+build() {
+ chmod -R 755 "$srcdir/SocksiPy-branch-$pkgver"
+ cd "$srcdir/SocksiPy-branch-$pkgver"
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/SocksiPy-branch-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}