summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-23 14:57:23 +0200
committerMarcell Meszaros2022-06-23 14:57:23 +0200
commit2fbce0a4aac9fd3ed106914d0a42fc353bc5f882 (patch)
tree0af79e90fbde088e407790c67c5306e939b5e385
parentec5f0ac121e402baf2651e3c00d1af5f4f1a89c1 (diff)
downloadaur-2fbce0a4aac9fd3ed106914d0a42fc353bc5f882.tar.gz
refactor: cleanup, formatting, use b2sums
-rw-r--r--.SRCINFO7
-rw-r--r--.editorconfig8
-rw-r--r--PKGBUILD42
3 files changed, 27 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5a536eb0838..736582c98dcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python2-soupsieve
- pkgdesc = A CSS4 selector implementation for Beautiful Soup - python2 version
+ pkgdesc = A CSS4 selector implementation for Beautiful Soup (legacy Python 2 version)
pkgver = 1.9.6
pkgrel = 3
url = https://github.com/facelessuser/soupsieve
arch = any
license = MIT
makedepends = python2-setuptools
+ depends = python2
depends = python2-backports.functools_lru_cache
- source = python2-soupsieve-1.9.6-3.tar.gz::https://github.com/facelessuser/soupsieve/archive/1.9.6.tar.gz
- sha256sums = 3fc0bf362090cfafb0b592b120c289d72b11ddab3717015a7a327e30e23e7f65
+ source = soupsieve-1.9.6.tar.gz::https://github.com/facelessuser/soupsieve/archive/1.9.6.tar.gz
+ b2sums = 2bd2f74e6974ad73c79c018f704fef600594c568471062c503a7fb1248e2cc1840011d31550f7573654f015016f0d3272778b0100e4701318a829f916f06698e
pkgname = python2-soupsieve
diff --git a/.editorconfig b/.editorconfig
deleted file mode 100644
index a467ee9a97a6..000000000000
--- a/.editorconfig
+++ /dev/null
@@ -1,8 +0,0 @@
-root = true
-
-[*]
-charset = utf-8
-end_of_line = lf
-insert_final_newline = true
-indent_style = tab
-tab_width = 4
diff --git a/PKGBUILD b/PKGBUILD
index 270ae2df715d..900533f0b6b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,39 @@
-# Maintainer: Daniel Peukert <daniel@peukert.cc>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Daniel Peukert <daniel@peukert.cc>
# Contributor: Felix Yan <felixonmars@archlinux.org>
-_projectname='soupsieve'
-pkgname="python2-$_projectname"
-pkgver='1.9.6'
-pkgrel='3'
-pkgdesc='A CSS4 selector implementation for Beautiful Soup - python2 version'
+
+pkgname='python2-soupsieve'
+_distname="${pkgname#python2-}"
+pkgver=1.9.6
+pkgrel=3
+pkgdesc='A CSS4 selector implementation for Beautiful Soup (legacy Python 2 version)'
arch=('any')
-url="https://github.com/facelessuser/$_projectname"
+url="https://github.com/facelessuser/${_distname}"
license=('MIT')
-depends=('python2-backports.functools_lru_cache')
+depends=(
+ 'python2'
+ 'python2-backports.functools_lru_cache'
+)
makedepends=('python2-setuptools')
# checkdepends=('python2-pytest' 'python2-beautifulsoup4' 'python2-html5lib' 'python2-lxml')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/facelessuser/$_projectname/archive/$pkgver.tar.gz")
-sha256sums=('3fc0bf362090cfafb0b592b120c289d72b11ddab3717015a7a327e30e23e7f65')
-
-_sourcedirectory="$_projectname-$pkgver"
+_tarname="${_distname}-${pkgver}"
+source=("${_tarname}.tar.gz::https://github.com/facelessuser/${_distname}/archive/$pkgver.tar.gz")
+b2sums=('2bd2f74e6974ad73c79c018f704fef600594c568471062c503a7fb1248e2cc1840011d31550f7573654f015016f0d3272778b0100e4701318a829f916f06698e')
build() {
- cd "$srcdir/$_sourcedirectory/"
- python2 setup.py build
+ cd "${_tarname}"
+ python2 setup.py build
}
# circular dependency on python2-lxml
# check() {
-# cd "$srcdir/$_sourcedirectory/build/"
-# py.test2
+# cd "${_tarname}/build/"
+# py.test2
# }
package() {
- cd "$srcdir/$_sourcedirectory/"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "${_tarname}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -Dm644 'LICENSE.md' "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ install -Dm 644 'LICENSE.md' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}