summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Mauderer2017-03-24 22:33:18 +0100
committerChristian Mauderer2017-03-24 22:33:18 +0100
commit0d042cd92a1496a70c8ac65f76ba2339ee2412b5 (patch)
treedc461c42400097d2b1cf58b4c7c444e181bd4071
downloadaur-0d042cd92a1496a70c8ac65f76ba2339ee2412b5.tar.gz
Create package.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7163a04632fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-sourcemap-git
+ pkgdesc = Parse JavaScript source maps.
+ pkgver = r62.95ebb1f
+ pkgrel = 1
+ url = https://github.com/mattrobenolt/python-sourcemap
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ makedepends = git
+ depends = python2
+ provides = python2-sourcemap
+ conflicts = python2-sourcemap
+ options = !emptydirs
+ source = python2-sourcemap::git+https://github.com/mattrobenolt/python-sourcemap
+ md5sums = SKIP
+
+pkgname = python2-sourcemap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d3370844804
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christian Mauderer <oss@c-mauderer.de>
+pkgname=python2-sourcemap-git
+pkgver=r62.95ebb1f
+pkgrel=1
+pkgdesc="Parse JavaScript source maps."
+arch=('any')
+url="https://github.com/mattrobenolt/python-sourcemap"
+license=('BSD')
+depends=('python2')
+makedepends=('python2-distribute' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=(!emptydirs)
+source=("${pkgname%-git}::git+https://github.com/mattrobenolt/python-sourcemap")
+md5sums=('SKIP')
+
+_gitroot=https://github.com/mattrobenolt/python-sourcemap
+_gitname=python2-sourcemap
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: