summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-10-26 14:11:42 +0200
committerPellegrino Prevete2021-10-26 14:11:42 +0200
commit9069a4cccd069ef1c5a08a1761435b031661aca0 (patch)
treeb1b1992850d6432ce18ffef4c23a5555bdf6145f
parent467b189d913505280a82261ffa1a9ee43d2ae8ac (diff)
downloadaur-9069a4cccd069ef1c5a08a1761435b031661aca0.tar.gz
Downgraded to 1.0.0 for broken python2 compatibility
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2812bc1e38bf..762943e2abe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-sphinxcontrib-serializinghtml
pkgdesc = Sphinx extension which outputs "serialized" HTML files (json and pickle)
- pkgver = 1.1.5
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/sphinx-doc/sphinxcontrib-serializinghtml
arch = any
@@ -8,8 +8,8 @@ pkgbase = python2-sphinxcontrib-serializinghtml
checkdepends = python2-pytest
checkdepends = python2-sphinx
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.5.tar.gz
- sha256sums = aa5f6de5dfdf809ef505c4895e51ef5c9eac17d0f287933eb49ec495280b6952
- b2sums = e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5
+ source = git+https://github.com/sphinx-doc/sphinxcontrib-serializinghtml#tag=1.0.0
+ sha256sums = SKIP
+ b2sums = SKIP
pkgname = python2-sphinxcontrib-serializinghtml
diff --git a/PKGBUILD b/PKGBUILD
index 00c2d82c8d1b..b7a64cc6d644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=sphinxcontrib-serializinghtml
pkgname=python2-$_name
-pkgver=1.1.5
+pkgver=1.0.0
pkgrel=1
pkgdesc='Sphinx extension which outputs "serialized" HTML files (json and pickle)'
arch=('any')
@@ -11,12 +11,12 @@ url=https://github.com/sphinx-doc/sphinxcontrib-serializinghtml
license=('BSD')
makedepends=('python2-setuptools')
checkdepends=('python2-pytest' 'python2-sphinx')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('aa5f6de5dfdf809ef505c4895e51ef5c9eac17d0f287933eb49ec495280b6952')
-b2sums=('e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5')
+source=("git+$url#tag=$pkgver")
+sha256sums=(SKIP)
+b2sums=(SKIP)
build() {
- cd $_name-$pkgver
+ cd $_name
python2 setup.py build
}
@@ -26,7 +26,7 @@ build() {
# }
package() {
- cd $_name-$pkgver
+ cd $_name
python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}