summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2018-04-29 23:45:22 -0700
committerShane Stone2018-04-29 23:45:22 -0700
commit204635bd4ba999b4b74ddc0a70df689205e68015 (patch)
treeb715e7837fc42ba474922b37e5cb150792b6fd7d
parentf1fd4a10356a18de2140c308fdce01c091ce20a6 (diff)
downloadaur-204635bd4ba999b4b74ddc0a70df689205e68015.tar.gz
Bump to v2.1.1 and remove mv command that is no longer necessary
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9fb897c4f6a..318e05d523a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = python2-spiceypy
pkgdesc = A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes.
- pkgver = 2.1.0
+ pkgver = 2.1.1
pkgrel = 1
url = https://github.com/AndrewAnnex/SpiceyPy
arch = any
license = MIT
makedepends = python2-six>=1.9.0
- makedepends = python2-numpy>=1.8.0
+ makedepends = python2-numpy>=1.12.0
+ makedepends = python-certifi>=2017.1.23
makedepends = python2-setuptools
- source = python2-spiceypy-2.1.0.tar.gz::https://github.com/andrewannex/spiceypy/archive/v2.1.0.tar.gz
- md5sums = be29fd2060b5a61f9f3e271835e82022
-
-pkgname = python2-spiceypy
depends = python2-six>=1.9.0
- depends = python2-numpy>=1.8.0
+ depends = python2-numpy>=1.12.0
depends = python-certifi>=2017.1.23
optdepends = python2-pytest>=2.9.0: testing
+ source = python2-spiceypy-2.1.1.tar.gz::https://github.com/andrewannex/spiceypy/archive/v2.1.1.tar.gz
+ md5sums = a32faf9c4b76c3257329e336c15be8fd
+
+pkgname = python2-spiceypy
diff --git a/PKGBUILD b/PKGBUILD
index 6f60002701ee..50e82513f03d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,17 @@
# Maintainer: Shane Stone <shanewstone at gmail>
pkgname=('python2-spiceypy')
-pkgver=2.1.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
arch=('any')
url="https://github.com/AndrewAnnex/SpiceyPy"
license=('MIT')
-makedepends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0' 'python2-setuptools')
+makedepends=('python2-six>=1.9.0' 'python2-numpy>=1.12.0' 'python-certifi>=2017.1.23' 'python2-setuptools')
+depends=('python2-six>=1.9.0' 'python2-numpy>=1.12.0' 'python-certifi>=2017.1.23')
+optdepends=('python2-pytest>=2.9.0: testing')
source=("$pkgname-$pkgver.tar.gz::https://github.com/andrewannex/spiceypy/archive/v$pkgver.tar.gz")
-md5sums=('be29fd2060b5a61f9f3e271835e82022')
+md5sums=('a32faf9c4b76c3257329e336c15be8fd')
prepare() {
mv SpiceyPy-$pkgver SpiceyPy-$pkgver-py2
@@ -23,20 +25,14 @@ prepare() {
}
build() {
- echo "Building Python2"
cd SpiceyPy-$pkgver-py2
python2 setup.py build
}
package() {
- depends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0' 'python-certifi>=2017.1.23')
- optdepends=('python2-pytest>=2.9.0: testing')
-
cd SpiceyPy-$pkgver-py2
python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- mv -v $srcdir/SpiceyPy-$pkgver/spiceypy/utils/spice.so $pkgdir/usr/lib/python2*/site-packages/spiceypy/utils/
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}