summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2017-10-23 20:02:37 -0700
committerShane Stone2017-10-23 20:02:37 -0700
commite9bb948a8d5b9dcae062bae56818718bfee097a3 (patch)
tree217c7faaeb016c0f7cc87b7d9872c03515612bd3
downloadaur-e9bb948a8d5b9dcae062bae56818718bfee097a3.tar.gz
Initial commit after completely splitting from python-spiceypy.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d020aa02494
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-spiceypy
+ pkgdesc = A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/AndrewAnnex/SpiceyPy
+ arch = any
+ license = MIT
+ makedepends = python2-six>=1.9.0
+ makedepends = python2-numpy>=1.8.0
+ makedepends = python2-setuptools
+ source = https://github.com/andrewannex/spiceypy/archive/v2.0.0.tar.gz
+ md5sums = 7115d8c054e46b21c85863bd42de0a3d
+
+pkgname = python2-spiceypy
+ depends = python2-six>=1.9.0
+ depends = python2-numpy>=1.8.0
+ optdepends = python2-pytest>=2.9.0: testing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72f88f3afeeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Shane Stone <shanewstone at gmail>
+
+pkgname=('python2-spiceypy')
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
+arch=('any')
+url="https://github.com/AndrewAnnex/SpiceyPy"
+license=('MIT')
+makedepends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0' 'python2-setuptools')
+source=("https://github.com/andrewannex/spiceypy/archive/v${pkgver}.tar.gz")
+md5sums=('7115d8c054e46b21c85863bd42de0a3d')
+
+prepare() {
+ mv SpiceyPy-$pkgver SpiceyPy-$pkgver-py2
+ cd SpiceyPy-$pkgver-py2
+
+ sed -e "s|#![ ]*/usr/bin/python[0-9]*$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python[0-9]*$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python[0-9]*$|#!/usr/bin/env python2|" \
+ -i $(find . -name '*.py')
+}
+
+build() {
+ echo "Building Python2"
+ cd SpiceyPy-$pkgver-py2
+ python2 setup.py build
+}
+
+package() {
+ depends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0')
+ optdepends=('python2-pytest>=2.9.0: testing')
+
+ cd SpiceyPy-$pkgver-py2
+
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}