summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2018-01-04 00:01:34 -0700
committerShane Stone2018-01-04 00:01:34 -0700
commitf1fd4a10356a18de2140c308fdce01c091ce20a6 (patch)
tree26f30e1c012b1cfa724fce40972a2e7ddf4a8edd
parent73f448f6acf13bcc425497dc30a91c88e281494e (diff)
downloadaur-f1fd4a10356a18de2140c308fdce01c091ce20a6.tar.gz
Update to SpiceyPy 2.1.0 with explicit mv call to fix spice.so problem.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1225482ed23e..c9fb897c4f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-spiceypy
pkgdesc = A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes.
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/AndrewAnnex/SpiceyPy
arch = any
@@ -8,11 +8,12 @@ pkgbase = python2-spiceypy
makedepends = python2-six>=1.9.0
makedepends = python2-numpy>=1.8.0
makedepends = python2-setuptools
- source = python2-spiceypy-2.0.0.tar.gz::https://github.com/andrewannex/spiceypy/archive/v2.0.0.tar.gz
- md5sums = 7115d8c054e46b21c85863bd42de0a3d
+ source = python2-spiceypy-2.1.0.tar.gz::https://github.com/andrewannex/spiceypy/archive/v2.1.0.tar.gz
+ md5sums = be29fd2060b5a61f9f3e271835e82022
pkgname = python2-spiceypy
depends = python2-six>=1.9.0
depends = python2-numpy>=1.8.0
+ depends = python-certifi>=2017.1.23
optdepends = python2-pytest>=2.9.0: testing
diff --git a/PKGBUILD b/PKGBUILD
index eb6a7a2849a9..6f60002701ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Shane Stone <shanewstone at gmail>
pkgname=('python2-spiceypy')
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="A Python wrapper for the NAIF C SPICE Toolkit (N66) written using ctypes."
arch=('any')
@@ -10,7 +10,7 @@ url="https://github.com/AndrewAnnex/SpiceyPy"
license=('MIT')
makedepends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0' 'python2-setuptools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/andrewannex/spiceypy/archive/v$pkgver.tar.gz")
-md5sums=('7115d8c054e46b21c85863bd42de0a3d')
+md5sums=('be29fd2060b5a61f9f3e271835e82022')
prepare() {
mv SpiceyPy-$pkgver SpiceyPy-$pkgver-py2
@@ -29,12 +29,14 @@ build() {
}
package() {
- depends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0')
+ depends=('python2-six>=1.9.0' 'python2-numpy>=1.8.0' 'python-certifi>=2017.1.23')
optdepends=('python2-pytest>=2.9.0: testing')
cd SpiceyPy-$pkgver-py2
python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
+ mv -v $srcdir/SpiceyPy-$pkgver/spiceypy/utils/spice.so $pkgdir/usr/lib/python2*/site-packages/spiceypy/utils/
+
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}