summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2012-04-26 12:16:19 +0200
committerMassimiliano Torromeo2012-04-26 12:16:19 +0200
commitcdd375e0e2b48117b39869dfaf7a91379c9fe13a (patch)
treebe6cfbc4e940463a335f8a919aace4fde821ded8
downloadaur-cdd375e0e2b48117b39869dfaf7a91379c9fe13a.tar.gz
Added python2-stomp.py package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8100131b4e37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-stomp.py
+ pkgdesc = Python2 STOMP client, supporting versions 1.0, 1.1 and 1.2 of the protocol
+ pkgver = 4.0.15
+ pkgrel = 1
+ url = https://github.com/jasonrbriggs/stomp.py
+ arch = any
+ license = Apache
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/stomp.py/stomp.py-4.0.15.tar.gz
+ sha256sums = 22ad080ad2a8b11bfcac8dbf6f4a0b0780a0e4eb742be85008a5ae359ce4e5f2
+
+pkgname = python2-stomp.py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a5eaddf6adb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python2-stomp.py
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="Python STOMP client, supporting versions 1.0 and 1.1 of the protocol"
+arch=(any)
+url="http://code.google.com/p/stomppy"
+license=(Apache 2.0)
+depends=(python2)
+source=(http://stomppy.googlecode.com/files/stomp.py-$pkgver.tar.gz)
+
+build() {
+ cd "$srcdir/stomp.py-$pkgver"
+ python2 setup.py install -O1 --root="$pkgdir"
+}
+
+md5sums=('c151d41d61db53177db9d80d90c11113')