summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:51:50 -0700
committerAnatol Pomozov2015-06-17 08:51:50 -0700
commit532678d00ad5cee1254226cfb8d84d7fa735fb89 (patch)
treec026eeeeaa333999bc395b73dd1057e7c83f078d
downloadaur-532678d00ad5cee1254226cfb8d84d7fa735fb89.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c097d54ea41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-straight.plugin
+ pkgdesc = A simple namespaced plugin facility
+ pkgver = 1.4.0.p1
+ pkgrel = 1
+ url = https://github.com/ironfroggy/straight.plugin
+ arch = any
+ license = MIT
+ depends = python2
+ source = https://pypi.python.org/packages/source/s/straight.plugin/straight.plugin-1.4.0-post-1.tar.gz
+ md5sums = e1a22847055f377fa4c9a99d733eb44c
+
+pkgname = python2-straight.plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c48264a7ebb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer:
+
+pkgname=python2-straight.plugin
+pkgver=1.4.0.p1
+_ver=1.4.0-post-1
+pkgrel=1
+pkgdesc='A simple namespaced plugin facility'
+arch=(any)
+url='https://github.com/ironfroggy/straight.plugin'
+license=(MIT)
+depends=(python2)
+source=(https://pypi.python.org/packages/source/s/straight.plugin/straight.plugin-$_ver.tar.gz)
+md5sums=('e1a22847055f377fa4c9a99d733eb44c')
+
+package() {
+ cd straight.plugin-$_ver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}