summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNabil Freij2015-06-26 10:02:11 +0100
committerNabil Freij2015-06-26 10:02:11 +0100
commit4e650faf442d89cad1fce936b582f11db3ed95e3 (patch)
tree3801d05f1a69c25c0519de7411cd477e84fa669a
downloadaur-4e650faf442d89cad1fce936b582f11db3ed95e3.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aab1de1158c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python2-sunpy
+ pkgdesc = Python library for solar physics
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://www.sunpy.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = python2-astropy
+ depends = python2-matplotlib
+ depends = python2-scipy
+ depends = python2-pandas
+ depends = python2-requests
+ depends = python2-suds
+ depends = python2-beautifulsoup4
+ optdepends = python2-sqlalchemy: for the database package
+ optdepends = python2-pytest: for running tests
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/s/sunpy/sunpy-0.5.4.tar.gz
+ md5sums = f52c17ad7fd9c18c46b860f5df150867
+
+pkgname = python2-sunpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd1529e9cb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nabobalis <nabil dot freij at gmail dot com>
+# Contributor: Nabobalis <nabil dot freij at gmail dot com>
+pkgname=python2-sunpy
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Python library for solar physics"
+arch=('i686' 'x86_64')
+url="http://www.sunpy.org/"
+license=('BSD')
+depends=('python2'
+ 'python2-astropy'
+ 'python2-matplotlib'
+ 'python2-scipy'
+ 'python2-pandas'
+ 'python2-requests'
+ 'python2-suds'
+ 'python2-beautifulsoup4')
+optdepends=('python2-sqlalchemy: for the database package'
+ 'python2-pytest: for running tests')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/s/sunpy/sunpy-$pkgver.tar.gz)
+md5sums=('f52c17ad7fd9c18c46b860f5df150867')
+
+package(){
+ cd $srcdir/sunpy-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: