summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNabil Freij2015-06-26 10:07:31 +0100
committerNabil Freij2015-06-26 10:07:31 +0100
commitc0694a0075c87c579ae58ae1ef6ef3d99da1c30f (patch)
tree38835148bb154c76c4e51c4173a7f48e7f81641b
downloadaur-c0694a0075c87c579ae58ae1ef6ef3d99da1c30f.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rwxr-xr-xPKGBUILD37
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02243c9483ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python2-sunpy-git
+ pkgdesc = Python library for solar physics
+ pkgver = 20150626
+ pkgrel = 1
+ url = http://www.sunpy.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = python2-astropy
+ depends = python2-matplotlib
+ depends = python2-scipy
+ depends = python2-pandas
+ depends = python2-requests
+ depends = python2-suds
+ depends = python2-beautifulsoup4
+ optdepends = python2-sqlalchemy: for the database package
+ optdepends = python2-pytest: for running tests
+ provides = python2-sunpy
+ conflicts = python2-sunpy
+ options = !emptydirs
+ source = git+https://github.com/sunpy/sunpy
+ md5sums = SKIP
+
+pkgname = python2-sunpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..83cc0dd78e2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Nabobalis <nabil dot freij at gmail dot com>
+# Contributor: Nabobalis <nabil dot freij at gmail dot com>
+pkgname=python2-sunpy-git
+_gitname=sunpy
+pkgver=20150626
+pkgrel=1
+pkgdesc="Python library for solar physics"
+arch=('i686' 'x86_64')
+url="http://www.sunpy.org/"
+license=('BSD')
+depends=('python2'
+ 'python2-astropy'
+ 'python2-matplotlib'
+ 'python2-scipy'
+ 'python2-pandas'
+ 'python2-requests'
+ 'python2-suds'
+ 'python2-beautifulsoup4')
+optdepends=('python2-sqlalchemy: for the database package'
+ 'python2-pytest: for running tests')
+provides=(python2-sunpy)
+conflicts=(python2-sunpy)
+options=(!emptydirs)
+source=(git+https://github.com/sunpy/sunpy)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+package(){
+ cd $srcdir/sunpy
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: