summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNabil Freij2016-05-25 08:38:28 +0200
committerNabil Freij2016-05-25 08:38:28 +0200
commitdad09f2f0eae79cda8e345aa4316ec70ec78da79 (patch)
tree18309b579965ce58ae79876d6a7bf14d3c159e20
parent8abf252c72bf24003e4e44985b6ecb5ea51c9848 (diff)
downloadaur-dad09f2f0eae79cda8e345aa4316ec70ec78da79.tar.gz
Version numbers
-rw-r--r--.SRCINFO82
-rwxr-xr-xPKGBUILD8
2 files changed, 7 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 740b39cbd1bd..6d04df12c88b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 13 12:05:35 UTC 2016
+# Wed May 25 06:38:19 UTC 2016
pkgbase = python2-sunpy-git
pkgdesc = Python library for solar physics
- pkgver = 20160513
+ pkgver = r6.8abf252
pkgrel = 1
url = http://www.sunpy.org/
arch = i686
@@ -26,81 +26,3 @@ pkgbase = python2-sunpy-git
pkgname = python2-sunpy-git
-pkgbase = python2-sunpy-git
- pkgdesc = Python library for solar physics
- pkgver = 20160513
- pkgrel = 1
- url = http://www.sunpy.org/
- arch = i686
- arch = x86_64
- license = BSD
- depends = python2
- depends = python2-astropy
- depends = python2-matplotlib
- depends = python2-scipy
- depends = python2-pandas
- depends = python2-requests
- depends = python2-suds
- depends = python2-beautifulsoup4
- optdepends = python2-sqlalchemy: for the database package
- optdepends = python2-pytest: for running tests
- provides = python2-sunpy
- conflicts = python2-sunpy
- options = !emptydirs
- source = git+https://github.com/sunpy/sunpy
- md5sums = SKIP
-
-pkgname = python2-sunpy-git
-
-pkgbase = python2-sunpy-git
- pkgdesc = Python library for solar physics
- pkgver = 20160513
- pkgrel = 2
- url = http://www.sunpy.org/
- arch = i686
- arch = x86_64
- license = BSD
- depends = python2
- depends = python2-astropy
- depends = python2-matplotlib
- depends = python2-scipy
- depends = python2-pandas
- depends = python2-requests
- depends = python2-suds
- depends = python2-beautifulsoup4
- optdepends = python2-sqlalchemy: for the database package
- optdepends = python2-pytest: for running tests
- provides = python2-sunpy
- conflicts = python2-sunpy
- options = !emptydirs
- source = git+https://github.com/sunpy/sunpy
- md5sums = SKIP
-
-pkgname = python2-sunpy-git
-
-pkgbase = python2-sunpy-git
- pkgdesc = Python library for solar physics
- pkgver = 20160513
- pkgrel = 3
- url = http://www.sunpy.org/
- arch = i686
- arch = x86_64
- license = BSD
- depends = python2
- depends = python2-astropy
- depends = python2-matplotlib
- depends = python2-scipy
- depends = python2-pandas
- depends = python2-requests
- depends = python2-suds
- depends = python2-beautifulsoup4
- optdepends = python2-sqlalchemy: for the database package
- optdepends = python2-pytest: for running tests
- provides = python2-sunpy
- conflicts = python2-sunpy
- options = !emptydirs
- source = git+https://github.com/sunpy/sunpy
- md5sums = SKIP
-
-pkgname = python2-sunpy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5788e1aeb98f..55df6f5c1a63 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Nabobalis <nabil dot freij at gmail dot com>
pkgname=python2-sunpy-git
_gitname=sunpy
-pkgver=20160513
+pkgver=r6.8abf252
pkgrel=1
pkgdesc="Python library for solar physics"
arch=('i686' 'x86_64')
@@ -25,8 +25,10 @@ source=(git+https://github.com/sunpy/sunpy)
md5sums=('SKIP')
pkgver() {
- cd "$_gitname"
- git log -1 --format="%cd" --date=short | sed 's|-||g'
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package(){