summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Galeotti2015-06-08 15:36:32 -0300
committerBruno Galeotti2015-06-08 15:36:32 -0300
commitd5ddd0830fdba6eaebabca24861cccd9f6681c27 (patch)
tree9345702d42aade0d1b17e0c925387f34cb17de5d
downloadaur-d5ddd0830fdba6eaebabca24861cccd9f6681c27.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1eabc28d7054
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-tabulate
+ pkgdesc = Pretty-print tabular data in Python.
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://bitbucket.org/astanin/python-tabulate
+ arch = any
+ depends = python2
+ depends = python2-psutil
+ source = https://pypi.python.org/packages/source/t/tabulate/tabulate-0.7.5.tar.gz
+ sha256sums = 9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e
+
+pkgname = python2-tabulate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5eea83e26d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bruno Galeotti <bgaleotti at gmail dot com>
+
+pkgname=python2-tabulate
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Pretty-print tabular data in Python."
+arch=(any)
+url="https://bitbucket.org/astanin/python-tabulate"
+depends=('python2' 'python2-psutil')
+source=("https://pypi.python.org/packages/source/t/tabulate/tabulate-$pkgver.tar.gz")
+sha256sums=('9071aacbd97a9a915096c1aaf0dc684ac2672904cd876db5904085d6dac9810e')
+
+build() {
+ cd "$srcdir/tabulate-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/tabulate-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1
+ find "$pkgdir" -name '*.py' -print0 |xargs -0 \
+ sed -i -e 's,^#!/usr/bin/env python$,#!/usr/bin/env python2,' \
+ -e 's,^#!/usr/bin/python$,#!/usr/bin/python2,'
+}
+
+# vim:set ts=2 sw=2 et: