summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaël Guillemenot2016-06-15 15:20:52 +0200
committerLaël Guillemenot2016-06-15 15:20:52 +0200
commit89e639ef77b0f8f0e5a3f69ef602c31fa53e31b4 (patch)
tree04c820340a9b443a1f107793ba476b3927dad252
parent8e40e1830ac8e383026dcd018c0c8cdf5a0c65de (diff)
downloadaur-89e639ef77b0f8f0e5a3f69ef602c31fa53e31b4.tar.gz
MAJ en v1.5.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--munin.patch21
3 files changed, 12 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2a23d795e56..59eceb69692a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-temper
pkgdesc = This is a rewrite of a userspace USB driver for TEMPer devices presenting a USB ID like this: 0c45:7401 Microdia
- pkgver = 1.2.1
+ pkgver = 1.5.1
pkgrel = 1
url = https://github.com/padelt/temper-python
install = python2-temper.install
@@ -12,10 +12,8 @@ pkgbase = python2-temper
depends = python2-setuptools
depends = python2-snmp-passpersist
provides = python2-temper
- source = https://github.com/padelt/temper-python/archive/master.zip
- source = munin.patch
- sha256sums = a335199bc8cdbc01a642d8336ab356dbcb6016a7b43c961908fa97bb5a634a3b
- sha256sums = 2f19940d78f04c72e85d3fed2e896179d71a3a750c069043d77f9adb59f6545b
+ source = https://github.com/padelt/temper-python/archive/v1.5.1.tar.gz
+ sha256sums = 9edd0fa91975d83edffbcc0211843815bd07305adddad21669de0467a9d487b0
pkgname = python2-temper
diff --git a/PKGBUILD b/PKGBUILD
index a98ac93659f2..b95c52af1ae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
pkgname=python2-temper
-pkgver=1.2.1
+pkgver=1.5.1
pkgrel=1
pkgdesc="This is a rewrite of a userspace USB driver for TEMPer devices presenting a USB ID like this: 0c45:7401 Microdia"
arch=('any')
license=('unknown')
-url=('https://github.com/padelt/temper-python')
+url='https://github.com/padelt/temper-python'
makedepends=('python-distribute')
install=${pkgname}.install
-source=(https://github.com/padelt/temper-python/archive/master.zip
- munin.patch)
-sha256sums=('a335199bc8cdbc01a642d8336ab356dbcb6016a7b43c961908fa97bb5a634a3b'
- '2f19940d78f04c72e85d3fed2e896179d71a3a750c069043d77f9adb59f6545b')
+source=("https://github.com/padelt/temper-python/archive/v${pkgver}.tar.gz")
+sha256sums=('9edd0fa91975d83edffbcc0211843815bd07305adddad21669de0467a9d487b0')
depends=('python2' 'python2-pyusb-beta' 'python2-setuptools' 'python2-snmp-passpersist')
provides=("${pkgname}")
prepare() {
- cd "${srcdir}/temper-python-master"
- sed -i 's/python/python2/g' "${srcdir}/temper-python-master/etc/munin-temperature"
- cd "etc"
- patch -Np1 -i "${srcdir}/munin.patch"
+ cd "${srcdir}/temper-python-${pkgver}"
+ sed -i 's/python/python2/g' "${srcdir}/temper-python-${pkgver}/etc/munin-temperature"
}
package() {
- cd "${srcdir}/temper-python-master"
+ cd "${srcdir}/temper-python-${pkgver}"
python2 setup.py install --root "${pkgdir}"
mkdir -p "${pkgdir}/etc/udev/rules.d" "${pkgdir}/usr/lib/munin/plugins"
- install -Dm644 "${srcdir}/temper-python-master/etc/99-tempsensor.rules" "${pkgdir}/etc/udev/rules.d/"
- install -Dm755 "${srcdir}/temper-python-master/etc/munin-temperature" "${pkgdir}/usr/lib/munin/plugins/temper"
+ install -Dm644 "${srcdir}/temper-python-${pkgver}/etc/99-tempsensor.rules" "${pkgdir}/etc/udev/rules.d/"
+ install -Dm755 "${srcdir}/temper-python-${pkgver}/etc/munin-temperature" "${pkgdir}/usr/lib/munin/plugins/temper"
}
diff --git a/munin.patch b/munin.patch
deleted file mode 100644
index ace5bf895fef..000000000000
--- a/munin.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- etc/munin-temperature.orig 2014-07-02 16:26:17.000000000 +0200
-+++ etc/munin-temperature 2014-08-29 20:42:59.770393653 +0200
-@@ -7,7 +7,7 @@
- #
- # This code is licensed under the GNU public license (GPL). See LICENSE.md for details.
-
--from temper.temper import TemperHandler
-+from temperusb.temper import TemperHandler
- import sys
-
- handler = TemperHandler()
-@@ -21,7 +21,8 @@
- devices = handler.get_devices()
- for device in devices:
- port = device.get_ports()
-- port_name = port.replace('.', '_')
-+ port_name = str(port)
-+ #.replace('.', '_')
- if is_config:
- if len(devices) > 1:
- print "temp_" + port_name + ".label Temperature in °C (port {0:s})".format(port)