summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Pomozov2015-06-17 08:51:59 -0700
committerAnatol Pomozov2015-06-17 08:51:59 -0700
commit3581dbdcfb0309d278c9dcc549919e3f6f2fc22e (patch)
treeb7aa4d9a9c7862c86859bcb27eafa40daccf61b9
downloadaur-3581dbdcfb0309d278c9dcc549919e3f6f2fc22e.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
3 files changed, 45 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..0bcc89d7f438
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-thrift
+ pkgdesc = Python bindings for the Apache Thrift RPC system
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://thrift.apache.org/
+ arch = i686
+ arch = x86_64
+ license = ASF
+ depends = python2
+ source = https://pypi.python.org/packages/source/t/thrift/thrift-0.9.2.tar.gz
+ sha1sums = 063de7774f55a9d4d22765416624d973cb27e742
+
+pkgname = python2-thrift
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bcc89d7f438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-thrift
+ pkgdesc = Python bindings for the Apache Thrift RPC system
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://thrift.apache.org/
+ arch = i686
+ arch = x86_64
+ license = ASF
+ depends = python2
+ source = https://pypi.python.org/packages/source/t/thrift/thrift-0.9.2.tar.gz
+ sha1sums = 063de7774f55a9d4d22765416624d973cb27e742
+
+pkgname = python2-thrift
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a22fee92f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+
+pkgname=python2-thrift
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='Python bindings for the Apache Thrift RPC system'
+arch=(i686 x86_64)
+license=(ASF)
+url='https://thrift.apache.org/'
+depends=(python2)
+source=(https://pypi.python.org/packages/source/t/thrift/thrift-$pkgver.tar.gz)
+sha1sums=('063de7774f55a9d4d22765416624d973cb27e742')
+
+package() {
+ cd thrift-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}