summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2021-01-23 11:59:45 +0100
committerTim Schumacher2021-01-23 11:59:45 +0100
commit3e7edf9ea052da4cb16a5debb2f43c54292a7bd7 (patch)
tree3e06e3f0ae53654fe13ea53c65b45f9a8e5009f0
downloadaur-3e7edf9ea052da4cb16a5debb2f43c54292a7bd7.tar.gz
Initial python2-titlecase package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6d1bb6c16d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-titlecase
+ pkgdesc = Python Port of John Gruber's titlecase.pl (old version with python2 support)
+ pkgver = 0.13.1
+ pkgrel = 1
+ url = https://github.com/ppannuto/python-titlecase
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-nose
+ depends = python2-regex
+ source = https://files.pythonhosted.org/packages/source/t/titlecase/titlecase-0.13.1.tar.gz
+ sha256sums = 5b34bea05a2b9dac22abc1455f23416b8f5f971d664b77230328dbaab5556f3d
+
+pkgname = python2-titlecase
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e0b41e25a64f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9c2745cf37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=python2-titlecase
+_module='titlecase'
+pkgver=0.13.1
+pkgrel=1
+pkgdesc="Python Port of John Gruber's titlecase.pl (old version with python2 support)"
+url="https://github.com/ppannuto/python-titlecase"
+depends=('python2' 'python2-nose' 'python2-regex')
+makedepends=('python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/t/titlecase/titlecase-${pkgver}.tar.gz")
+sha256sums=('5b34bea05a2b9dac22abc1455f23416b8f5f971d664b77230328dbaab5556f3d')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ # Avoid conflicts with the Python 3 package
+ mv "${pkgdir}/usr/bin/titlecase" "${pkgdir}/usr/bin/titlecase-py2"
+}