summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:51:53 +0100
committerBartłomiej Piotrowski2018-01-07 13:51:53 +0100
commitddf9e12dcc59071bab420af3bc22614da7c8027d (patch)
treecb2b9afab773572bc8b7de99b86557d4c0232090
downloadaur-ddf9e12dcc59071bab420af3bc22614da7c8027d.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b130027d6743
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-tlslite
+ pkgdesc = SSL/TLS library in pure Python supporting RSA and SRP ciphersuites
+ pkgver = 0.4.9
+ pkgrel = 2
+ url = http://trevp.net/tlslite
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2
+ optdepends = python2-crypto: fast RSA operations and fast ciphers
+ optdepends = python2-gmpy: fast RSA and SRP operations
+ optdepends = python2-m2crypto: fast RSA operations and fast ciphers
+ optdepends = python2-tackpy: run an X.509 server using TACK
+ options = !emptydirs
+ source = https://pypi.org/packages/source/t/tlslite/tlslite-0.4.9.tar.gz
+ sha256sums = 9b9a487694c239efea8cec4454a99a56ee1ae1a5f3af0858ccf8029e2ac2d42d
+
+pkgname = python2-tlslite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..105aaf769a04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 196971 2016-11-26 21:01:09Z bpiotrowski $
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-tlslite
+pkgver=0.4.9
+pkgrel=2
+pkgdesc="SSL/TLS library in pure Python supporting RSA and SRP ciphersuites"
+arch=('any')
+depends=('python2')
+makedepends=('python2-setuptools')
+optdepends=('python2-crypto: fast RSA operations and fast ciphers'
+ 'python2-gmpy: fast RSA and SRP operations'
+ 'python2-m2crypto: fast RSA operations and fast ciphers'
+ 'python2-tackpy: run an X.509 server using TACK')
+url="http://trevp.net/tlslite"
+license=('custom')
+options=(!emptydirs)
+source=(https://pypi.org/packages/source/t/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+sha256sums=('9b9a487694c239efea8cec4454a99a56ee1ae1a5f3af0858ccf8029e2ac2d42d')
+
+prepare(){
+ cd "${pkgname#python2-}-$pkgver"
+
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+build() {
+ cd "${pkgname#python2-}-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname#python2-}-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}